Download

Transparent Materials Not Working Only After Building Lighting

Hello,

I’ve been learning UE4 and trying to understand how to implement a material transparency/fade on actors. My work was going really well up until I did executed “build lighting” in my environment which sort of broke it. Being that I’m new to UE4, my web search for support has come up fruitless but that could be the product of me not knowing how to properly describe the problem.

In lieu of that, I’ve included a video that captures the fade working and then breaking after I do the build lighting setup.

I was wondering if someone could take a look and provide some guidance on where I should be looking to debug this issue, or possibly the words I need to properly explain the issue elsewhere. Any direction would be really appreciated! Thanks. :slight_smile:

Thanks to the help from the Unreal Slackers discord (more specifically Adriel), turns out the issue was that my objects were all set to Static instead of Stationary.

The way I understand it now is that static actors are expected never to change, so when I build the lighting, it expects that the mesh will always be there. This is why the material fades away as expected, but the mesh stays because it’s supposed to be static, even though I’m running code that changes it. Once I changed the objects to "stationary, everything worked as expected, complete with a slight change on how my shadows were rendering.

In your material properties, try setting “used with static lighting” to true.

I had the same problem with my translucent local outline material, every time I built lighting it would render with the world grid material, which lead me to believe it was not correctly compiling the shader. Sure enough, flagging static lighting to true worked for me.

To my knowledge this doesn’t apply to material rendering, as long as you are only changing the material you can do whatever you want including animating the vertices.

1 Like