Download

Translucent materials: How to get perfect alpha blending on dark backgrounds?

Hello everyone,

I’ve having a problem with alpha blending in UE 4.5.1.

Does anyone know how to get the alpha blending to look the same in the editor as it does on the texture preview screen?

The alpha blending looks correct on brighter backgrounds, but rather bad on dark backgrounds.

(The original TGA texture is attached in case you want to give it a go)

Hi!

It looks like sRGB in “Details” for your texture is not selected. And alpha looks wrong, because gamma corrected. Try check/uncheck sRGB and compare result. Default sRGB must be set.

Hi svv3dUDN, thanks a lot for taking the time to reply to my question and apologies for getting back to you so late.

In the mean time, I have done more testing and have reached the conclusion below.

As I am new here, I don’t know if this is a known issue - or whether I am doing something wrong…

PROBLEM DESCRIPTION
32-bit textures are too bright and exhibit alpha artifacts when used in translucent materials whereas a 24-bit + an 8-bit texture look correct (see the attached screenshots).

HOW TO REPLICATE THE PROBLEM

  1. Download AlphaTest.zip via this link: Copy.com
  2. Load AlphaTestLevel.umap
  3. Observe the difference between the two sprites, and compare the two materials.
  4. The material with the 32-bit texture exhibits alpha artifacts and is brighter than the material with the 24 + 8-bit textures.

ADDITIONAL NOTES

  • PNG textures with transparency are affected the same way as 32-bit textures.
  • Turning *sRGB *off in the texture settings only seems to make the 24+8-bit textures brighter (despite the fact that the tooltip says that it should be turned off when using “alpha channels individually as masks”).
  • The texture sample type in the 24+8-bit material needs to be set to ‘Color’ as opposed to ‘Linear Color’ in order to look correct.