Translucent material render order problem

When setting two objects to have a translucent material, the render order gets messed up from certain camera angles. I’ve put some images below to illustrate the issue. Is this a bug, or am I misunderstanding something?

Setting the translucency sorting priority is not an option for this, as the player needs to be able to move to both sides.


Hi Univentive -

This is a current limitation of the engine currently with translucent materials in the deferred pipeline. You can try a few different solutions to try to fix the issue for you. The first one you have already ruled out, the Translucent Sort Priority. Next you could play with the Scale Bounds settings for each plane mesh, but because of the closeness of the meshes, at least in your example, this will be extremely hard to accomplish. Lastly and the one that I would probably suggest more depending on your setup would be to give your pictures 3D frames of an opaque material, this thickness will stop the camera from seeing the planes from the side angle which is where your major overlapping will be occurring is in the side to side top to bottom transitioning.

Thank You

Eric Ketchum

Thanks Eric!