Translucent material No Shadow in Play Mode

translucent material give shadow only in editor or simulate mode , but none in play mode no shadow for translucent material in play mode ? is that a bug ?

Everything is checked for the light source and the game object : volumetric shadow, translucent shadow

i use UE 4.25

Hey AdieAkira,

I don’t have a perfect solution, but I was having the exact same issue yesterday and found a workaround.
I haven’t had a chance to test this very much yet, so I can’t guarantee it will work in all situations.

But try adding an Arrow Component to your Actor hierarchy. Then mark “HiddenInGame” = FALSE for the Arrow.
You can reduce the Arrow’s size to something like 0.0001 or whatever so it’s effectively invisible.

In my case, I had a CapsuleComponent as the Root and a few StaticMesh Components as children (plus SpringArm / Camera). One of the StaticMesh Components had a translucent material applied and all the settings properly set (e.g. Volumetric Translucent Shadows = TRUE). But while the shadow would always be visible in the Editor / Simulation, it always disappeared when Playing. However, doing the above miraculously turned the translucent shadow on during PIE.

I have no idea why this works. I was working on something totally different and then suddenly saw the translucent shadows working and figured out how I did it!

When I have more time I will dig into the code to see exactly why this is working, but hopefully this helps for now.