translucent fabric - shadow intensity

I have a little problem to somehow controll the shadow intensity on my fabric material. See attachment. Is there any option to control the shadow intensity? Also, I have laborated very long time to create translucent 2 side fabric similar my renders. It looks good now, but could looking better.Thanks

Also connect the 0.99 to the Opacity Mask slot and use the “Cast Shadow as Masked” option in the material’s translucency settings. This will cause the material to render solid shadows, which seem mores appropriate for such a material.

On a related note: Did you try to recreate this material with an subsurface scattering shading model? You could probably get nicer results for this kind of material, with better performance compared to using translucency.

I have tried pretty everything to make material better result. Unfortunatelly, when the shadows looked nice, the other aspects like opacity was with some issues in render. So This basic option keep still as a best option. How can I activate opacity mask slot with my shading model? I couldn’t find the option “Cast Shadow as Masked” in my version 4.7

“Cast Shadow as Masked” is under Lightmass > Lightmass settings.

(If you can’t find an option you can just type the name in the search bar on top of most panels to find it)

thanks, Cast Shadow as Masked definitelly helped to me :slight_smile: Now the shadow is nice and solid.