Translucency clipping


  1. Create a default level in a third person project.
  2. Insert an SM_DoorFrame object from the starter content.
  3. Create a new material, set Blend Mode to Translucent.
  4. Plug in a distinct base color texture and set opacity to 1.
  5. Walk around the mesh and notice the issue (only seen from one side though, not from the other).

Farther part displays in front of the closer part.

There are some old discussions about this, I also remember trying different options (Lighting Mode, Separate Translucency) and console switches, but to no success, and since I run into this issue again in my project I decided to point it out again.

A real-life example where this is an issue would be a tunnel/corridor with windows on both sides etc. I think separating each glass piece into a separate mesh works OK, but this is somewhat cumbersome.

Thank you for your time.

I’m afraid separate meshes might be the best way to go. Sounds like a classic “sorting” issue. I believe there are some per object settings under the rendering tab>translucent sort priority. But the only way to get consistent behaviour is to brake things up. I hope that helps.