Transitioning from a Sequence into gameplay

Hey y’all, I’m calling in to ask about a persistent problem I’ve been having. I have a few cutscenes in my game made with Sequencer and, while it is indisputably more useful than Matinee, it has a quirk I don’t know how to handle.

If I play an animation on the player character during the Sequence and then return to gameplay, the character is frozen in that animation. I’ve tried running a Stop Animation event at the end of the Sequence, but that doesn’t change anything.

Up until now I’ve been cheating a little by using a copy of the character, one that blips in and out of sight when in use, but this introduces new problems, namely syncing the two copies up so that the transition between cutscene and gameplay looks natural.

So, I’m sure there’s a simple fix for this. I’ve played plenty of games made in Unreal with this sort of thing. Any help would be deeply appreciated.

Been a few days. I don’t want to get on anyone’s nerves, I’m just well and truly annoyed by this issue. I can’t accept that I’m the only person who’s run into this problem.

does it work if you set the character’s Mesh Animation mode back to “Use Animation Blueprint” at the last frame of the sequence?

In my case I set it to “Use Animation Asset” at the beginning, and to “Use Animation Blueprint” at the end.

109509-animationmode.jpg

That’s a really good idea – but it’s not working for me. Even on a tiny Sequence, where I set it to Asset, play an animation, then set it back to Blueprint, the animation is still going.

I’ve tried setting and resetting his animation mode through an event track as well, without result.

He does visibly “flicker,” however, near the end of the Sequence when I set him back to Anim Blueprint, like he’s trying to revert to his traditional animation.

You can try that :
I noticed in my project, that if the Camera Cuts in the sequence is longer than the sequence end, the gameplay is stuck after that.
Set the camera ended at the same frame than the Red marker (end of sequence).

I’m having the same problem. After the sequence the character just resets to his original sequencer pose.
There must be a solution for this. (That thing with the cameras isn’t working either.)

  • Are you still in 4.13 ?

  • You can try, Adding a binding to your sequence End (bind event on the sequenceplayer)
    And then in BP, resetting the Animation Mode after the sequence end.
    If it’s not working, you can assume it’s not the Animation mode.

  • How did you use your main character blueprint ? you drop the Blueprint from the content browser or droping it from the world outliner ?

  • Check your character is Possessable (right clic on his track and you should see Convert to Spawnable)

I spend 2 weeks to understand how the sequencer works… and it’s not a full success :slight_smile:

But. you can check some tricks.
First, ensure you have the Realtime rendering in the preview (Ctrl+R)

Try to set the camera cut ending at the same frame than the sequence.
Sometime, having 1 frame or more of camerashot after the sequence’s end, lock my gameplay. Sometime not, and I don’t know why.

If you put a Blueprint character in the sequencer, you have to configure some stuff inside.
If your character is animation graph driven, check all your meshes inside and put them in Custom mode, then put the root in animation graph mode.

In the sequencer, you can add a track on the main character mesh to set the mode in Custom mode (or animation only)
There is also a track to add on each mesh, to add the “preview in Editor” without that, there is a chance your mesh will not be animated at all…

After all this, when the Sequence is finished, in Blueprint, set the actor in AnimationBlueprint mode.

In my project, I recreate a PlaySequence Box, to automatizing all this stuff… and it’s a lot of try and retry. Some flags can drastically change things.

. Hi there! Nope 4.14. Upgraded to 4.15 yesterday. Same issue. Even though it worked for a short time. And I thaught I had done something. But it just turned out to be random chance. Rebuilt the entire sequence in 4.15. Still not working.

. Tried. And the set animation mode command was ignored. So it must be some problem with the animation (I have a bone driven facial rig… with lots of bones. that might be a problem.)

. content browser.

Thanks for your support!
I’ll try calling the animation from within the animation BP. You have another suggestion?

hmm… I’m not getting this part.

“If your character is animation graph driven, check all your meshes inside and put them in Custom mode, then put the root in animation graph mode.”

Where exactly. I’m sorry. It confused me.

It depends of your character.

In general, the main character is a blueprint, inside, there is a capsule component, and inside, a mesh component (the one created by default from Character inheritance)

You can select the root and set the animation mode, but you can also select the mesh component to do so (it’s the same)
In my case, because of the head blendshape, I set the head mesh on the default mesh, and I add another mesh component, containing the body. So my character have 2 meshes, but sharing the same skeleton

What I wanted to say is, every meshes have her own animation mode, but only the “default” one really drive stuff.
You need to set all meshes in Custom mode if you want to drive the character from a sequence.
Then after play, reset the animation mode to BP driven.

In fact, only the main Mesh (the one displayed in the BP) seems to affect the play, so I kept all other meshes to custom mode and switch the main mode only.

Oh my God it’s working!
I did it by setting the actor to Animation Blueprint Mode but not after an Event.
I did it by “Bind Event OnStop” connected to Custom Event that was independent of the sequence. It seems that the Sequencer itself has trouble resetting the Character Blueprint after finishing.

Sry. I just read your answer! THX!

I don’t trust events and specialy the ones near the last frame, sometime, they are not launched at all.

Always bind an event on OnStop.
And a safer method for mandatory code, is creating a delay with the sequence length. So Even if the sequence is killed by anything, the code is called.

In my project, I create a new C++ latent function to play a sequence, so I can do stuff before and after and sending the “continue” slot when the sequence is really finished.

that’s why my latent, check at each update if the sequence IsPlaying()… at least it’s synch with the inside behaviour ^^
But that way I can add a skip sequence feature, binded on a pad button, and each tick I can stop the sequence if a variable skip is true.

Wow. The Delay Method works fine as well. I’m just curious how it relates to things like “Pause the Game”. What I want to say is:
How it is possible to conect the delay to the input of the player. (Also skip sequence option)

That sounds really usefull! I wish I had the brain to just script my way out of the Blueprint Pasta. Btw. Do you know how to blend smoothly between a sequence camera and the player camera. “The set view target with Blend”- solution isn’t working. I guess it’s because the sequence “stops existing” and the game recognizes the default view as the Player Control.

In theory, if you use the main gameplay character and not a copy, the camera is blended.
If you right clic on your character track, you should see “convert to spawnable” if your character is possessed.

In our project, we have a camera manager in C++ to blend on tick…
But in the UE camera examples the blend is effective and the SetViewTargetWithBlend is working.
Try to set the blend at 5s so you have time to see if it works.

Making him spawnable kind of made things strange. The animation in the sequence isn’t playing. The player camera is off and there is a copy of the player character standing in the center of the room.