Transitioning from a Sequence into gameplay

Of course… I misunderstood. Sorry. Yes, my character was posessed all the time. Still the “set view target with Blend” isn’t working. It’s really wierd and it frustrates me. Because it’s the solution that is suggested everywhere. Even people having a similar scene setup, with a video playing at the beginning seem to be able to make it work.

Maybe you can try the new 4.15 feature, to rebind at runtime the real player character.

Thx! I’ll try this out as soon as I buy a new PC. Selling my current!
Here is my progress:

Ok. I tried it. Nothing happens. How am I supposed to make the System understand that I want a smooth transition from the Sequence Camera to the Gameplay camera? It just jumps as you can see in the beinning of the video.

Did you ever sort this out? I’m having the same issue.

For the camera, we used a custom behaviour, and at the end of the sequence, we take the position of the cam and put it in our cam behavior.

For the body animation, we still working on that…

I found that adding a “default slot” at the end of our animation graph help a lot.
We don’t need to modify the animation method on the squeletal mesh, all animation played on the mesh bypass the animation graph
(and maybe we can add blend there…)

Hello friend! Sorry I found a different, more complicated solution to the issue with animations not blending in sequencer when using bp char using anim bp.

Some people talk about the “default slot” solution but I never managed to make it work for me. Could you please explain how this goes? Exactly how does this go in the anim graph? say I have a state machine, would it simply be a matter of having a slot node between my “locomotion” state and my final animation pose? should I just drop in the animations I want to blend in sequencer in the anim graph and blend them all through a node? How exactly do I tell them to all belong to the default slot?

Im sorry for the confusion, Ive just found it tricky to get it working, and understanding your solution would solve everything for me!

Our solution is a little bit complicated too, in order to make it work, you have to :

  • Use an actor possessable in the sequence So you have to drop your main actor in the scene instead of using the spawn location.
  • Then drag n drop your scene actor into the sequencer.
  • In the animation graph, just before the output, add a slot node with “default slot name” (you can look in the sequencer, when you play an animation, it’s by default this slot.
  • Use at least UE 4.15

That way, when the sequence start, the animation will cut the animation graph (and you can add some blending in the animation tree) and at the end of the sequence, the sequencer remove all he add.

In our case, we decided to add fate from/to black before all cinematics so it mask all kind of gliches.

Hello there! I’m sorry to revive such and old topic but I stumbled with this problem and I spent waaay to much time trying to figure out how to solve it, so in case someone reaches this post, I hope this helps.

Basically, if you follow this guide:

You’ll notice two problems:

  1. You can’t see the blend between the character anim blueprint current animation and the animation defined in the cinematic.

  2. The value of the DefaultSlotInterp can’t be changed.

To solve the first issue you have to check the “Call in editor” checkbox in the SetDefaultSlotInterp function.
To solve the second one you have to add a track of the “adding” type instead of the “Absolut” type.

Hope this helps. Regards!

Man! I was not able to change this Value at all!
I searched for so long that dame little detail! ahah

THANKS SO MUCH!!!

Will try this out at home. Thx so much!