Trail on a moving mesh with TXAA

I have the following rendering artifact when temporal anti-aliasing is enabled:

How could I fix it without turning off TXAA?

Hi ZoltanE,

Can you provide a little more information that may help resolve the issue you’re having? If so, I have a few questions:

Have you tried setting this up in another level with the same effect?
In the Volume are you adjusting anything other than check box for “AA Method”?

Can you also provide your system specs?



Thank you for the prompt reply!

In a new “Default” map the issue is not present.
This pawn’s camera does not override anything.

The PPVolume has the following settings:

  • Vignette Intensity: 0.6
  • Lens flares Intensity: 0
  • Motion blur amount: 0
    If I disable the PPVolume then the issue is not visible because motion blur blurs the whole thing into mush. :slight_smile:
    Pasting the volume onto the default map does not introduce the problem.

My system is:
Windows 7 x64
Unreal Engine 4.1.0
Intel i7-4770K
GeForce GTX 760 (2Gb) with driver 335.23

Okay, I found what causes this: a SceneCapture2D actor.

Here is how the map is laid out:

The SC2D is facing away from the map, looking at a black box with a white object. Both of those meshes are culled when looking outside the main building. When “Capture Every Frame” is false (or the capture actor is deleted) then everything looks normal. Max view distance or FOV setting doesn’t change anything.

The problem is that the motion vectors for the object (which is not moving when the camera is moving) are busted. Bad motion vectors provide bad reprojection (the swimming problem). Looks like Scene Capture triggers the bug.

BTW, this isn’t TXAA (that’s NVIDIA’s tech) but rather a different temporal AA.