Download

to developers, ue 4.14 crashes! - Error: 0x887A0006 - 'HUNG'

Unfortunately, this didn’t work for me either.

For fix this issue Im suggest:

  1. Complete remove NVIDIA driver and NOT install latest version of GPU driver, because usually its have a lot of bugs (tested)
  2. Install NVIDIA Driver from official site + If not NOT use 3D Stereo feature - DONT INSTALL IT! Most of old card didnt support it, but sometimes affect on crashes!
  3. Disable auto update in NVIDIA GeForce Experience
  4. If your GPU have build-in overclock - so, go down GPU and VRAM freq to base settings, if your GPU is overheat on old GPU card its can make device eject - as result DXGI_ERROR_DEVICE_HUNG - aka Device Removed
  5. Checkup status of NVIDIA Optimus, if you have Intel GMA + NVIDIA old GF - its can make a some problems, because can be activated even for not supported device.

If this didnt help, reinstall driver from vendor CD/DVD or vendor site (depend upon device vendor).

*(config - Alienware m17xR4 i7/32GB/NVGF675MX/W10x64/UE4.14)
P.S. dont forget comment, if its help you.
*

I am using a GTX560 Ti…
I tried changing GPU stat, but it seems to not working to me.
and error message is same.

Unreal Engine is exiting due to D3D device being lost. (Error: 0x887A0006 - ‘HUNG’)

Hi folks.

Can you confirm that you are using the latest drivers for your graphics cards?

Also, we will be releasing a QFE (“quick fix”) soon to help with this crash. The QFE contains more fixes than just the r.gpustatsenabled disabling, so please be sure to try it out when available and let us know your results.

Thanks

hi,

i had this crash too with 4.14, and it seems that the **r.gpustatsenabled 0
** trick fix the problem :slight_smile:

It seems to crash when trying to paint on landscape (device lost). Or maybe it is caused by compiling shaders, not sure. Using GTX 550 Ti.

same, Asus GTX570 DirectCuII

seems like NVIDIA did something strange from 5th generation of gpus… earlier works great no issue reports and one guy told me he has gtx460 and works flawlesly. Google “device hung” and u will find from 5th generation and up that are crashing for this issue in some games also ,for ATI & u will find nothing.

yeah! cant wait to try the fixed version! thanks Stephen! :slight_smile:

IMPORTANT INFORMATION!

Hi everyone. We have released a QFE (“quick fix”) that should help resolve many cases of this crash. Please download the QFE for 4.14.1 from here: https://forums.unrealengine.com/showthread.php?3147-Current-Available-Quick-Fix-Solutions and run the executable to install the fix.

We hope this resolves the issue for most users, and we intend to include this fix in an upcoming 4.14 hotfix in January.

Please let us know your results.

Seems to work for me where it used to crash before. Will update if I find any related crashes. Thank you for fixing it :slight_smile:

does this QFE work with UE4.14 built from source too ?

Github users can integrate the commit directly (must be signed into your Github account to view link) https://github.com/EpicGames/UnrealEngine/commit/8e949bebcaa830dc7ea73950b062e30d67c4ea0f

Cheers

i tried both the quick fix on a launcher version, and the source edit on the github version, both still have the crash.

it happens when i change too many material slots too quickly in the editor. it doesn’t seem to crash if i edit the materials while the viewport is set to wireframe, and it doesn’t crash if i edit materials through blueprint code; i can swap between random materials as much as i want, on tick, without any problems.

its editing several material slots, in quick succession, in the details panel, that causes the crash.

on 4.13, it works perfectly, i can edit materials without any problem, and on 4.14 and 4.14.1, it causes a crash almost every time i edit a few material slots.

Hi Scott. Sorry to hear you are still experiencing a crash. With this QFE (and upcoming hotfix), we expect it to fix a majority of the cases but still believe there to be additional ones. Unfortunately you seem to be experiencing something similar but different from the issue we fixed.

So we can investigate your case further, please post a new bug report on the UE4 Answerhub (to the ‘Bug Reports’ section) and provide all details (including hardware) so we can attempt to reproduce this ourselves. Be sure to mention that you have already installed the QFE.

Thanks

Digging thru stuff I found another related crash. I opened BP_Sky_Sphere, clicked on Sky Sphere Mesh, and it crashed. I also use the QFE and run on GTX 550 Ti with 375.86 drivers.

The crash is not related to a particular asset, I manage to reproduce it very often with a standard third person project just created. You just have to play a bit with materials on the main char or open panels where there is a material or mesh preview. This bug is a real problem. Is there anyone who tested any previous versions of 4.14 which are ok? I cannot go to 4.13 as my assets are not compatible with it, but maybe an earlier version of 4.14 will do?

My laptop has an Intel 3000+Nvidia 540m (optimus) with Windows 10. The Intel drivers are 9.17.10.4459 and the Nvidia drivers are 376.48. The Intel drivers are updated ones from Microsoft because Intel basically gave everyone the middle finger; when asked to update the 3000 series drivers to Windows 10. Everything else is up to date, power settings are optimized for maximum performance, all power saving features have been disabled, all cores unparked, hdd is defragged etc etc. I have edited my console variables to include r.gpustatsenabled=0. Lastly, I made a shortcut, to the editor, that I can right-click and ensure that I run it with the Nvidia card.

What happens is I load up the game editor, open up a blueprint, select the mesh portion of it, then try to mouse-over things like the mesh or the material. As soon as I do, GPU usage shoots up to 100% and hangs(running MSI Afterburner to see GPU stats), then the program crashes with either a graphics removed or hung error. Over and over again… It’s not crashing from temperatures or anything like that. This bug is 100% repeatable; on my laptop. This was supposedly fixed in a recent QFE patch, but it didn’t fix it. How there has been a patch to 4.14.2 and it still isn’t fixed.

(Bug report section wasn’t letting me post and kept giving me errors)

CCan you attach your crash logs as well so the team can take a closer look?

When I put the -d3ddebug option on the shortcut, it gives me an error every time saying “dx11 feature level 10.0 is required to run the engine.” However, when it’s not there, the editor opens up just fine. This was the only log I could produce.