to developers, ue 4.14 crashes! - Error: 0x887A0006 - 'HUNG'

heres what im doing. i import my fdx model with animation.
there is no animation for my model in the content browser.
i double click my model and this is where ue 4.14 crashes!

im hoping you guys can fix this,but until then im going back to 4.13 ( i hope i can still dl it on the website!)

here i copied the crash log:


Fatal error: [File:D:\Build++UE4+Release-4.14+Compile\Sync\Engine\Source\Runtime\Windows\D3D11RHI\Private\D3D11Util.cpp] [Line: 176]
Unreal Engine is exiting due to D3D device being lost. (Error: 0x887A0006 - ‘HUNG’)

UE4Editor_Core!FDebug::AssertFailed() [d:\build++ue4+release-4.14+compile\sync\engine\source\runtime\core\private\misc\assertionmacros.cpp:332]
UE4Editor_D3D11RHI!TerminateOnDeviceRemoved() [d:\build++ue4+release-4.14+compile\sync\engine\source\runtime\windows\d3d11rhi\private\d3d11util.cpp:176]
UE4Editor_D3D11RHI!VerifyD3D11Result() [d:\build++ue4+release-4.14+compile\sync\engine\source\runtime\windows\d3d11rhi\private\d3d11util.cpp:225]
UE4Editor_D3D11RHI!FD3D11DynamicRHI::GetQueryData() [d:\build++ue4+release-4.14+compile\sync\engine\source\runtime\windows\d3d11rhi\private\d3d11query.cpp:135]
UE4Editor_D3D11RHI!FD3D11DynamicRHI::RHIEndDrawingViewport() [d:\build++ue4+release-4.14+compile\sync\engine\source\runtime\windows\d3d11rhi\private\d3d11viewport.cpp:562]
UE4Editor_RHI!FRHICommandList::EndDrawingViewport() [d:\build++ue4+release-4.14+compile\sync\engine\source\runtime\rhi\private\rhicommandlist.cpp:1347]
UE4Editor_SlateRHIRenderer!FSlateRHIRenderer::DrawWindow_RenderThread() [d:\build++ue4+release-4.14+compile\sync\engine\source\runtime\slaterhirenderer\private\slaterhirenderer.cpp:486]
UE4Editor_SlateRHIRenderer!TGraphTask<FSlateRHIRenderer::DrawWindows_Private'::35’::EURCMacro_SlateDrawWindowsCommand>::ExecuteTask() [d:\build++ue4+release-4.14+compile\sync\engine\source\runtime\core\public\async askgraphinterfaces.h:868]
UE4Editor_Core!FNamedTaskThread::ProcessTasksNamedThread() [d:\build++ue4+release-4.14+compile\sync\engine\source\runtime\core\private\async askgraph.cpp:932]
UE4Editor_Core!FNamedTaskThread::ProcessTasksUntilQuit() [d:\build++ue4+release-4.14+compile\sync\engine\source\runtime\core\private\async askgraph.cpp:679]
UE4Editor_RenderCore!RenderingThreadMain() [d:\build++ue4+release-4.14+compile\sync\engine\source\runtime\rendercore\private\renderingthread.cpp:320]
UE4Editor_RenderCore!FRenderingThread::Run() [d:\build++ue4+release-4.14+compile\sync\engine\source\runtime\rendercore\private\renderingthread.cpp:454]
UE4Editor_Core!FRunnableThreadWin::Run() [d:\build++ue4+release-4.14+compile\sync\engine\source\runtime\core\private\windows\windowsrunnablethread.cpp:74]

Hey Artistchampion,

I have a few follow up questions about your issue.

  1. Are you able to reproduce this by importing the model into a new 4.14 project?
  2. Does this occur with other models with animations (the animation is not imported and attempting to open the model causes the crash)?
  3. Does this occur when attempting to open models without animations?

If the original model will reliably cause this crash when imported, can you provide a copy of the asset/animations to help us investigate the issue on our end?


Doug Wilson

Hey Artistchampion,

Additionally, can you run the editor again from the UE4.exe file with the -d3ddebug command line argument and then get the project logs from the crash?

hi 1 i didnt try to reimport it into a new project.
2 yes i tested a small blender fbx with animation. still crashed. my original model was from milkshape 3d
3 no, the editor opens. no crash. i double clicked the default chair.
4 last question. im very new to ue i have no idea how to do that.

i cant test it any more. ive already uninstalled 4.14 and reinstalled 4.132.
hope you guys can fix this sometime, one other note i always get a note about needing to update my video card driver. i tried but i cant find the driver recommended. (possible cause?) i dont think so really.
i could send you my fbx model if you want.
thankyou very much for the very quick response!! :slight_smile:

i made a default cube in blender, rigged it and animated it. imported it into 4.14 & it still crashed. i dont think its my model

For the D3D logs, you should be able to navigate to your engine installation at Epic Games\4.14\Engine\Binaries\Win64. From here you’ll find the UE4Editor.exe file which you will need to make a copy of. Right click the copy and select properties. In the text box that should say something like “UE4Editor - Copy.exe” you will need to add a space after .exe followed by -d3ddebug. Apply this change and then launch the editor directly from the copied file. This should produce a log file with relevant logging when the crash occurs. Additionally, please provide the cube along with the animations you setup for it?

I’ve had about 5 crashes in the last 30 minutes in cascade.

One was simply turning off a particle module.

Others were adding particles.

This is unusable at this point… it’s just ridiculous.

hi Doug.
i downloaded 4.14 again. i found out what i was doing wrong. verrry stupid mistake when i imported my model. i forgot to click the import animation button!
this fixed it!! it doesnt crash anymore.

sorry for wasting your time. and thanks for all the help guys! happy uediting! lol :slight_smile:

It has happened twice to me today, while opening the default unreal mannequin the program simple crashes.

well i think i spoke too soon. i thought the crash problem was gone. but its back. :frowning:

all im doing…
i import my model with animation. i click on import animations
it imports my model and the animation. but my animation is black in the content browser.
i can drag the animation into the scene, run it & see the animation.
but this is where ue crashes, … if i double click my model or the animation. ue crashes.

ive tried to update my video card driver but it tells my i already have the best driver for it.
i could buy a much better video card but id like to know what someone at ue (the developers) recommend 1st.
(note. 4.13 never crashes) i could go back that i guess, but i want all the new cool stuff.

Hello I am also a blender user and have not had any problem with 4.14 yet. Is it possible for you to share a model that causes the crashes? The blender file if you don’t mind.

If it’s from Blender it could be an issue with the Blender FBX exporter

I’ve had issues with Blender to Unreal using the FBX exporter but never a full crash of Unreal. Maybe there is a bone scale issue. That has given me errors before which may lead to a crash on other systems.

my model is from milkshape 3d. but it also crashes with models from blender.

i played around with the settings with the fbx importer when i load my model. i double clicked the animation & it opened normally. but then i double click the model or switched to skeleton & ue 4.14 crashed.
ill share my model if you want to test it.
i was wondering if anyone would take a screen shot of your fbx importer settings with a model with animation. so i can see what settings your using.
for now thou. im going back to 4.13. i never have any problems with that one.

hi Doug. i will try what you suggested. all also provide my model soon. thanks!

im not sure if this means anything. but most of the time when ue crashes my pc has a little message saying that my video card kernel stopped working & has recovered…

hey paul would you mind sharing your pc specs? and graphics card?
if you havent had any crashes,really?

id like to know what os u have & graphics card. thanks if u can do this

I’ve had crashes with Unreal yes but mostly due to my own mistakes. Also I did experience this crash that you speak of when I downloaded someones testfile from the ANSWERHUB. The problem there was an EMPTY that was created(they were using 3ds MAX I imported it into Blender) made Unreal crash when you imported as SKELETAL MESH. Anyway I have more than 1 pc running Unreal so I can list other specs.

Xeon e5 - 1620 3.6ghz
24gig DDR3 ECC ram
Geforce gtx 970 & Quadro K600(in same pc yes)
Windows 10

i have windows 7 ,nividia geforce gtx 460m
4.14 crashes alot for me. most of the time its when i double click the animation. which is all black like it didnt import
i wonder if its my video card? seems like im the only one having problems with it crashing. :frowning:

thanks for leaving your specs :slight_smile:

Hi everyone.

With the latest releases, we are aware that many users are experiencing a variety of similar crashes with the error message: Unreal Engine is exiting due to D3D device being lost. (Error: 0x887A0006 - ‘HUNG’). For these crashes, something is causing your graphics card to hang, and the engine responds by crashing. Here is the link to the #1 crash in 4.14 - Unreal Engine Issues and Bug Tracker (UE-37999)

Unfortunately we have not been able to reproduce this crash internally at Epic, and we have not been able to narrow down any specific hardware or drivers that contribute to the issue.

If you are able to determine a definite reproduction case (especially if it occurs across multiple computers), please share the details with us!

Additionally, we would appreciate anyone who is experiencing a crash like this to run the UE4Editor.exe with the command line: -d3ddebug
This will add additional DX information to your project logs. After you crash, please gather the log file and attach it to a post in the Bug Report section on the UE4 Answerhub (additional information about how to log a bug report in my signature)

Thank you for your help.