Download

Time of Day Level Looks Bad

Hi everyone,

I have a project open and when I do New → Level → Time of Day in order to test the new Volumetric Clouds, then the results looks very bad. Here a screenshot:

Why is that? I have 4.26.0 running and my graphics card is a 1080Ti. Doesn´t matter if RayTracing is on or off in the project settings.

When I watch online videos about that time of day/ volumetric cloud topic things look much more realistic then in my case. In my case for example the directional does not get blurred by the clouds and the clouds are way to dark on the bottom.

Here an example with another cloud material:

image


Also way darker than in the YT video where I got this material from and also the directional not being blurred.

Would be great if anyone could help me out.

Thanks,
Marcus

The clouds will be very dark until you put the atmospheric actor in there, did you do that?

Hi ClockworkOcean,

thanks for your answer. The SkyAtmosphere actor is in there.

All I say is, that’s the problem I had. Nothing else comes to mind…

maybe your lighting or graphic settings in unreal are really low?

Your scenes exposure is not set correctly and you have bloom disabled.

Hey guys,

thanks for all of your answers. Arkiras nailed at least one point, I turned on the bloom already. It looks much better now, but when the sun hides completely behind a cloud it still often looks very bad. (just a hard disappearing with no transition)

I played with the exposure before, but with different exposure the clouds also do not look right (to dark) for my likings. Here is an example:

To get a feeling, the ground is albedo value of 0.21
The clouds look pretty dark, except the one in the BG. I wonder why.

Note that I used this material/scene since I thought it looks more realistic:

However, the Atmosphere Settings should be changed to something more realistic and also the material of the ground. It is set to an albedo of 1 which is unrealistic.

When I use Unreals default daytime volumetric cloud level it also looks unrealistic in my optinion, even with correct exposure and bloom. I see some people having the same bad quality, only with tweaked altitude and time settings certain shots look good.

If anyone knows more, would be awesome.

Thanks guys,
Marcus

Probably not that far off honestly. Clouds absorb very little light, almost all of it gets scattered through the cloud through multiscattering.

Your screenshot looks like it is adjusting the extinction/albedo color based on the altitude but I don’t know. I’m not watchin a 40m video to find out, sorry.

In general if you don’t want a dark bottom to your clouds you actually have quite a few options:

  1. Make your cloud less dense. Easy way to do this is to just multiply your final extinction by a small number before plugging it into the input. As I recall, this is what all of the materials in the Volumetrics plugin do (the final multiplier is a param called “Density”)
  2. In the volumetric output, increase the mutliscattering contribution and/or reduce the multiscattering occlusion.
  3. Use a higher multiple scattering approximation octave. I think in the default TOD level it is set to 1, raising that to 2 should give you a brighter result in some spots.
  4. Adjust the skylight cloud bottom occlusion in the cloud actor, and the cast shadow intensity in the directional light. I find these usually dont have a very strong impact, and are probably best left alone.

I’m fairly certain that material was intended to be a learning example not something people would use in their projects. The texture it uses doesn’t even tile correctly…