Time dilation for actor/mesh?

This is what I’ve done inside the ‘Cube’ Blueprint actor class: Screenshot - 6d17a751fdd8d217d177a6142f336ebd - Gyazo

Unsure what I’m doing wrong here, since the cubes time dilation is still not being affected when I activate a global time dilation (within my player blueprint) [Slow-motion]. The cube is affected by the slow motion too.

​in short, when i activate slow motion, the cube is still affected by the slow mo so the custom time dilation i set up in the cube blueprint is not being used for some reason.

can anyone point out what ive done wrong or what a possible solution is? Trying to make the cube not be affected by the global time dilation essentially.


Are you simulating physics on the cube?

Yeah I am.

Afaik, custom time dilation does not affect physics simulation. Global time dilation does.

It should work fine if you were to drive the movement with a movement component / timeline, though.

edit: perhaps a solution here is to let physics object perform their simulation and slow down everything else (the non-physical entities) with Custom Time Dilation.

do you think allowing the actor to socket onto the player could also bypass this? Like pressing E onto mesh and it then is connected to the player and ignores the time dilation.


I want to use the Custom Time Dilation node in a simple actor with only a static mesh but it doesn’t seem to affect it… Global Time Dilation does though…
In my case, I have simulate physics disabled.
Is there some kind of setting needed to make this work? I basically want to slow this object’s speed when pressing a certain key.

Thanks in advance!

Same question here. I need Custom Time Dilation only affect certain actors, but including also physic simulations and everything else. Did you find a solution?

Check out this post: