Download

Tiling Seams ! proplem with blending multiple hires Textures with a mask

hi as the pictures shows, i have a problem to create a seamless blend material.
i need to blend 4hires textures together - but when iam zooming in thera are this annoying seams.

my mask is a 4k texture (rgba)
should i create a procedural mask? - maybe with “generate band” or sth like that?
does anybody have an idea how to avoid this bad seams

iam grateful for any advice

pic0.JPG60e843f4d701d9303eabd862038a3e4aed565ec7.jpegedff2a362b175484e0b21cf304a7215b91c65db9.jpegpic3.JPG

thank you
best regards
simon

Probably fiddle with mask-textures compression settings and/or mip generation method. Try setting a sharper mip generation, it might solve it from close-up.

This might also be an issue with your image itself, where the values don’t actually meet properly in the middle and there is a gap between the squares. This could also be some texture filtering, so mess with bi-linear filtering/point sample filtering.

Hope one of these solutions works for you!

hi dec 1234
thank you for the fast reply,

the textures has no mipmaps, and no pixel mistakes (tested in photoshop) so the basic tiles are clean and seamless - the same with the 4k texture mask.
i switch the filter method from the texture mask to “default texture group” to “bi linear” , “tri linear” the best solution was with filter method “nearest”. but the bad seams are still there.

as i can see during playing with the filter method, i think its a pixel problem of the mask texture - because the resolution is limited to 4k?
maybe there is a way to avoid masking with textures?

if all you need are masks like that you can do that with coordinate based masks. for example take the red component of the uv coords, subtract 0.5 from it and ceil it. this should give you a very crisp mask and might solve your problem.

thx for the idea, but the seams are still visible.

Can we see your settings for one of those textures?

And just FYI, increasing the resolution of a mask like this is a waste. I have made an identical mask with a 2x2 pixel map and if it has nearest filtering and no mip map, it flawlessly works. So I’m curious about your texture files.

i wasnt sure about the size of the mask, thx for the info.
in picture one the settings of the maskmaskSettings.JPG

okay the seams comes from my image texture coordinate - i set the tiling to 2 - to fit the image into the mask
without the uv tiling the seams are clean…
sry for this noob questions - but is there a alternative method instead of the texture cord to fit the images into my mask ?

set tiling mode of your texture to clamp, you will then find it won’t tile, so you need to move each texture with the UV by adding or subtracting, but the seams should go

also mask compression is terrible, parts of other channels compress into each other and contaminate, I thought the whole point of a separate compression for masks would be so this didn’t happen but it seems useless to me, I either use grayscale images or set the mask to UI uncompressed

yes thats it :smiley:

thank you so much - i set the tiling again to 2, 2 and the image textures to clamp ! also the mask to “UI…” then add and substract the uvs to offset the images.
and now the ugly seams finally gone :-D.seamless.JPG
i wonder why ceil doesnt work / or floor and the clamp node (min max)
perhaps I’ve overlooked a little thing.

thank you again !!!