Tiled World LOD Settings

When I generate a landscape LOD through level details (world composition), the static mesh it produces is always around 1k vertices no matter what the details percentage is set to. Is this correct ? If it is then what’s the point of having more than 1 LOD if they’re all the same ? Perhaps something to do with no Simplygon license ?


“Details percentage” is used for simplifying static meshes with Simplygon.
When no Simplygon is installed LOD generator will remove all static meshes from LOD map. Only landscape actors will be simplified. Landscapes have their own simplification settings. “Landscape Export LOD” controls which landscape LOD level should be used for creating static mesh proxy.


I have not got the time to test it out with 4.8 yet, but is it completely unloading the far tiles and as we get closer they pop up out of no where like 4.7 and older versions ?

World composition loads/unloads tiles according to distance specified in “Layers”. By default all tiles assigned to “Uncategorized” layer which has distance 50000 units, which is 500 meters. You can always create a new layer (+ button) and set bigger distance like 2000000 (2km) and assign tiles to a new layer. In Kite demo we use 5km I believe, after that distance tiles replaced with their simplified versions.

That is if we have Simplygon installed right? otherwise the tiles just get hidden?

Ok, thanks for that. So I’ll have to make all low poly static meshes manually (including trees - I know you can bake foliage into textures but they look fake if you do) if I don’t have Simplygon ? It’s a shame that a major part of the pipeline is using a 3rd party program that you need a license for. Never mind :slight_smile:

Simplygon is only required to for merging and simplifying static meshes in the source tile. You can always create simplified tile manually. Kite demo was shipped with built LOD sub-levels, we do have Simplygon :slight_smile: If you have Kite demo, you can use ‘stat levels’ console command during game to see which tiles currently loaded in simplified version, their names will be with LOD1 suffix.

So using generate lods only works when simplygon is installed?

Now i’m use 4.20.Generate static mesh proxy somehow become default setting.Is there anyway to change that cause it take quite a long time to calculate the proxy mesh and i need the landcape only