Tiled landscape material

Hi, I have been having difficulties with painting materials onto my landscape.
Even after all shaders compile and lighting is built, with only one layer painted on the landscape looks like this:

I did a test in a seperate level within the same project using the same landscape mesh size and material and it works how I want it:

The only differences between the two are more complicated lighting and much more static meshes (that sit within the landscape) within the one that isn’t working.

Any ideas what is causing it?

I also made a copy of the level and deleted all static meshes and after rebuilding lighting it looked fine.
However if I deleted all meshes except the white one seen below (which forms the walls of an iregular shaped pit that the landscape is the ground of) then the colour variation across segments is seen in the shadow.

So does this mean the variations are there no matter what, but being in shadow makes them much more visible?

I think what you are trying to do is have all the textures tile correctly?

If so, select one of the textures, and in the Details > Geometry > Select, choose Select Matching Material. This will select every piece of the ground that has that material. Now in the same geometry section, select Alighnment, and then probably Surface Planar Floor.

Let me know if this works or if you need any help. First time answering.

Hello Jsleight,

Would you mind showing me how you have your material set up?

Also which version of the engine are you running?

Try adding a ‘Skylight’ as an ambient fill like where your shadows are being cast by the buildings to see if this resolves the issue.

Let me know what you discover, and if you have any other questions.


What you are referring to is BSP brushes which is a different monster entirely :slight_smile:

Hi Andrew, thanks for the reply.

I’m running 4.7.
This is the material setup at the moment using landscape layer blends.

However I have also tried with layer weights and it is the same result, even if I just put a normal single layered material on.

The skylight had no effect either, whether I placed it close or far from the shadow.

I did another test, which you might also be able to do to see if it’s just my machine. Opened a brand new default level, placed in a landscape with just the standard ‘M_Ground_Gravel’ and then put a cube from the ‘shapes’ folder in the content browser on top of it and scaled up to be quite large. Adjusted world settings to the below so that shadows were better.


And I still end up with this result

It’s as if the static mesh is staining whatever component is beneath it?

Thanks, for your help

Thanks for the help anyway!

So you material set up is a bit different than what I am used to seeing. It also seems like you are using the same texture sample multiple times and using the same ‘Landscape Layer Coordinates’ to scale/tile them as well. This could be the source of your issue.

Here is another user who was having troubles with his landscape, and I provided him with a screenshot and explanation of how I set up my own materials.

Landscape Painting Issue

Have a look at this post and see if the answer I provided also helps you find a solution. If you try this out and still are experiencing your issue, or if you have another question pertaining to landscape materials let me know!


Tried setting the material up as you had shown but it still doesn’t seem to work, and as I said even if it’s just a standard material it still does it so I don’t think it’ the material.

I figured out a bit of a work around that will work for this project, I increased the section size to max (255 x 255), increased sections per component to 2 x 2 and reduced the number of components to only 1 x 1. This gave me pretty much the same overall resolution as what I originally had but having only one component means none can be different shades. This wouldn’t work if I needed a higher res landscape though…

Thanks again for your help