Third Person Character is stuck through floor and then falling on Spawn

So the problem I have is, my character is getting stuck in the middle of the floor, the player start is higher enough than the floor but as soon as it spawns, it falls quickly until it gets stuck. The floor I’m using is the default one and I checked and it has collision. My character is using the Character Pawn Class. I didn’t use to have this error, so I don’t know if it’s a bug or if I changed something I shouldn’t have, although almost everything is at default… I searched in the forums for this issue, but I couldn’t find anything. Please help me solve this, I’m pretty sure I just made a dumb and simple mistake. Thanks for reading

Could you show the hierarchy of the actor - the components that make this blueprint.

Is is safe to assume that it works fine with no PhysicalAnimation component?

Sure, here they are


Sadly no, I just try deleting everything related to Physical Animations in a duplicate BP and the behavior remains the same

Of course, both the mesh and the capsule have Simulate Physics unticked like this


All righty, lets keep digging. How about Construction Script or the Begin Play event? Any script in there that could have altered the way things used to be?

And how are those:

Also, when you say stuck - does it mean you cannot move or that the geometry is penetrating / overlapping? As in, this kind of stuck:

Image from Gyazo

Could you double check whether either the mesh or capsule component has Simulate Physics ticked?

Thank you so much for trying to helping me and I apologize for not answering sooner. Both Begin Play and the Construction Script are empty and everything else is practically just movement events, everything used to work fine having the exact same events. When I say stuck I mean it just tries to go over but can’t, almost as if something is keeping it there. Let me see how I can show you. And as for the Capsule Component, it’s an unusual one, my character is spherical, but that didn’t use to be the problem neither. This is a photo of it

This is what happens. I can move around but can’t go outside the floor block and can’t jump.



So what I didn’t realize is that in order to disable event tick from the beginning there’s a setting option in Class Defaults to do that, it’s called Start with Tick Enabled. Instead of unchecking that box, I used the function Set Actor Tick Enabled to disable Tick, but if in the Class Defaults, Start Tick is Enabled, the function does nothing. And so I was running Tick which was setting the World Location of the Capsule where the mesh was, that is why it seemed like it was fighting to be positioned on top of the floor.

Thank you Everynone for trying to help me, although it was indeed my dumb mistake from the beginning. I will keep this post if it can help someone with the same problem, even though it is very specific.

Ha, glad you got it to work!