Thermal Post Process Shader

Hello there, I’ve been looking into getting a Thermal Vision mode Post Process Shader to work, I’ve been slowly learning about Post Process Materials and Shaders when I found this post to help get a jump start. However the effect achieved so far is still off from the effect I would like.

Now I’ve tried various things like cranking the output of the shader, because typically that works with normal materials making them glow, but it doesn’t seem to work here. I have also tried plugging some scene and pixel depth nodes into places to see what results I get, but to no avail.

I would really appreciate some pointers in the right direction, even the slightest tips can help.

Here is how mine is looking so far.

The results are quite nice however I would like it to be less sharp. It also has the issue of appearing strangely through other meshes(which you can see in the second picture, it appears white), I am sure this is because of the custom depth being used. I have tested making everything render at a custom depth, but then their default materials in combination with the shaders show up bright white.

I am aiming for more of a blurry look not unlike the image below which another person has done, but refuses to provide hardly any assistance or pointers in the right direction. As you can see in their version, they have a really nice blurry look to them, and the characters fade into the blue-purple colour over distance and when being occluded through objects, and everything seems to be rendering in that purple colour, but also the characters behind the walls appear less intense and more blurry, So obviously they are working the shader based on depth from the player as well as some form of occlusion to reduce the intensity of the effect.

Also here is a picture of Splinter Cell Blacklist which has another nice effect of which it seems to incorporate some sorta scene depth and apply the blue colour on that it so that the further some things are, they darker blue they appear to simulate some natural ambient temperatures. It also has a less intense blur to the point that the normal material detail of the character can still be made out.

Now I’ve managed to get the depth fade colour to work properly through some experimentation. I have tweaked it some more so it is a bit more noticeable than in my screenshot, but the effect is still there.

I changed what was plugged into the B slot of the last Lerp node, what I have there now is this:

Also, I have tried to use the Depth of Field for the characters camera but it didn’t seem to work, when I took the thermal vision shader out of the blendables, the Depth of Field effect worked, the effect also seems to disable antialiasing, and glows that materials will have due to a cranked up emmisive output.

I am unsure of how to go about fixing this.


I am really liking the progress! The default version of the Shader you have looks good already, but keep up the strong work!

Thanks mate, although I didn’t really come up with it, I found it on another thread, although I have added to it and do have an okayish understanding of how it works. I’m still not progressing as much as I would like with it and I’m still stuck in those areas that I mentioned.

BUMP: Still looking for any form of help with this, thanks.