There's an error I can't fix

Hello, I made cards in my game but after reading them, it gets stuck by pressing q again. 2. After walking over the papers, I get an error as you can see in the picture. Can you help me fix this?alt text

You need to make sure the reference you trying to remove exists and it’s valid. So add a IsValid node before Remove From Parent:

I tried to do what he said, but I was not fully able or did not work. Can you show me where to add and where to connect the target.

I did what I said but it didn’t work or I couldn’t. Can you show me exactly where to add it.

Exactly behind every “Remove from Parent” node. The input object in “IsValid” is the same that you’re connecting in “Remove from Parent”.

Also, is not a good idea the way you’re connecting the resulting widget from “Create HUD …” to “Remove from Parent”. You should put the result in a variable and use that variable to connect to “Remove from Parent”.

What exactly should be the behaviour of this script?

I added isvalid as you said. The error I received has been resolved, but a new problem has occurred. The text in the photo I added doesn’t go anymore when I move away from the paper.

While doing this code, my aim was as follows. I read the paper when I press the Q key and the paper goes away when I walk away. Apart from that, when I press the q key again, I want the paper to go off the screen again, but I couldn’t do it.

Looks like the part i marked is checking the wrong widget. Plug WP Oku instead of Not1.

When I do as you said, I keep getting the error again.

Do not connect anything in the “Is Not Valid” pin of the “IsValid” node of the “OnActorEndOverlap”:


You need to check the existence of both widget and remove if one or both exist.

So the center part becomes:

I did so, but as I explained above, the article remains still, still not going.

I did as you showed, but I still get an error. When I clicked on the error, I marked the place it showed in the picture.

I did, but the error is still not resolved. I showed the error in the picture.

I did, but the error is still not resolved. I showed the error in the picture.

I did, but the error is still not resolved. I showed the error in the picture.

Missing a “IsValid” node in the Q line. That’s why the error.

I did it this way, but I’m still getting the error.

I have it arranged this way, but the error continues. Where am I making a mistake?

Just test this one and it works fine. Instead of wires all around, I saved the created widget in variables.

Since 2 pieces of code are the same, I used a macro Remove. To create it, go to left panel, press to add new macro and set this logic and inputs/outputs:

There’s only one place I can’t understand, how exactly are widgets
you made a variable and recorded as what?