Download

The UE4 Vr template doesnt work with movable volumes?

Hi,
i am stuck for ages with this problem, hopefully somebody can help me out. I just started a new level, and here it is very important that i can lift myself a bit. Like an elevator. Usaually very easy in all other templates. Just make a matinee with a mesh going up, and the character follows the mesh. But in the VR template things work different. So i tried it allready with attaching a blocking volume to it, but then it doesnt work anymore while the volume has to be changed into movable. I tried all kinds of collision types. I made a little youtube of it. The left platform is static and with a blocking volume. Than one works. But the one next to it, which moves, doesnt work at all!
[video]https://youtu.be/82FnDvmujmg[/video]

I have the feeling this problem is way bigger than just a click somewhere:confused::slight_smile: maybe i need to change something in the VrPawn blueprint, to set the height from head to 1.80m, and then it works (?). But i have no clue how to do that!

Ya there is no character movement built into the VR pawn so you can only teleport onto surfaces but not move up or down. You could try adding one yourself but it would be easier to use mordentral’s VR Expansion Plugin.

Just follow the guide step by step here https://bitbucket.org/mordentral/vrexpansionplugin/wiki/How%20to%20add%20the%20plugin%20to%20a%20blueprint%20only%20project%20-%20Step%20by%20Step and you will have it up and running within half an hour. To put the functionality into your pawn you need to change the class setting from pawn or whatever it is to vive pawn I’m not exactly sure of the wording as I’m in work at the mo. Take a look at the example project he has and see the class setting in his pawn. You will also gain new movement modes, climbing abilities and lots more.

holy moly tcla75, i get very excited to see this and the links. I really really have to try this. Only problem is that i am a bit scared to ruin my project (4.16 vive), and the question if its possible to ruin it :slight_smile: I will make some backups and try that out. If i can do this too in my project it would make such a huge difference gee! thanks man!

hey almost i am there :slight_smile: Somehow i do something wrong in the pawnclass. I tried all classes but it goes wrong. But there is something happening, with the trigger i i can walk suddenly :slight_smile: But maybe i do something weird right now? I can change several classes, and also in several places. in the: HMDLocomotionPawn and the BP_MotionController,… i read the info but cannot find it where it goes wrong. Hopefully you have the golden tip :slight_smile:

check out the Example Template as a reference. I made it specifically to show how to set things up.

thanks mordentral, stupid enough i missed your example project! I tried to open it with 4.16 though, but cannot open it because it was created with a newer version. Is your example project 4.17 allready?
i tried this one: https://bitbucket.org/mordentral/vrexppluginexample/downloads/

Yeah its on 4.17 now, the template is always on the latest released version so that I don’t have to keep massive file copies.

thanks a lot mordentral, this plugin looks so good!!

The project wont open in 4.17 btw, weird, i will try it again.

Step by step installation guide might help you.

thanks again man! but i did that allready, everything seems be really good now. You really did a good job in providing all the data. All installed and ready. Only do something wrong in the pawn class i think. Thats why your example project will be such a great help. But it wont start on 4.17! (also not with 4.16) Are you sure you have uploaded the right project?
This is the message when i open it with 4.17.1luktNIETvr.png

It still has to be compiled, the plugin is c++, you can’t just initially launch of from the launcher without building a Dev build of it first.

This is to reduce how much I have to host files as well as make sure it works across versions.

I am using 4.17.1 currently with it.

oeh man i am sorry, now i get it!:slight_smile: this will work right now:) looking forward to try at monday,… my vive is gone for a few days