"The system cannot find the path specified." In Unreal Engine 5

I’m trying to package a level but It gives me an output log like this.
Is there a way to fix this issue? Should I roll back to UE4?
Here’s the log
UATHelper: Packaging (Windows): OodleDataCompression: Display: Oodle v2.9.5 format for pak/iostore with method=Kraken, level=4=Normal
UATHelper: Packaging (Windows): LogPakFile: Display: CompressionFormat 0 [Oodle] : 594 files, 84438771 → 18633994 bytes
UATHelper: Packaging (Windows): LogPakFile: Display: CompressionFormat 1 [Zlib] : 0 files, 0 → 0 bytes
UATHelper: Packaging (Windows): LogPakFile: Display: CompressionFormat 2 [None] : 1301 files, 39431228 → 39431228 bytes
UATHelper: Packaging (Windows): LogPakFile: Display: Added 1895 files, 58943451 bytes total, time 1.81s.
UATHelper: Packaging (Windows): LogPakFile: Display: PrimaryIndex size: 30278 bytes
UATHelper: Packaging (Windows): LogPakFile: Display: PathHashIndex size: 46225 bytes
UATHelper: Packaging (Windows): LogPakFile: Display: FullDirectoryIndex size: 61498 bytes
UATHelper: Packaging (Windows): LogPakFile: Display: Compression summary: 22.07% of original size. Compressed Size 18633994 bytes, Original Size 84438771 bytes.
UATHelper: Packaging (Windows): LogPakFile: Display: Encryption - DISABLED
UATHelper: Packaging (Windows): LogPakFile: Display: UnrealPak executed in 1.854693 seconds
UATHelper: Packaging (Windows): UnrealPak terminated with exit code 0
UATHelper: Packaging (Windows): Copying NonUFSFiles to staging directory: C:\Users\AlexHeller\Documents\Unreal Projects\TPS 5.0\Saved\StagedBuilds\Windows
UATHelper: Packaging (Windows): ********** STAGE COMMAND COMPLETED **********
UATHelper: Packaging (Windows): ********** PACKAGE COMMAND STARTED **********
UATHelper: Packaging (Windows): ********** PACKAGE COMMAND COMPLETED **********
UATHelper: Packaging (Windows): ********** ARCHIVE COMMAND STARTED **********
UATHelper: Packaging (Windows): Archiving to D:/New folder
UATHelper: Packaging (Windows): ********** ARCHIVE COMMAND COMPLETED **********
UATHelper: Packaging (Windows): BUILD SUCCESSFUL
UATHelper: Packaging (Windows): AutomationTool executed for 0h 0m 37s
UATHelper: Packaging (Windows): AutomationTool exiting with ExitCode=0 (Success)
UATHelper: Packaging (Windows): Updating environment variables set by a Turnkey sub-process
UATHelper: Packaging (Windows): The system cannot find the path specified.
UATHelper: Packaging (Windows): The system cannot find the path specified.

1 Like

Bump. I’m currently getting a fatal error when launching the executable, wondering if this is related. I tried following UE 5 Fatal Error ExitCode=-1073740940, but my “Package Compression Format” was already set to Oodle. I even tried disabling Io Store, which was described as a temporary fix, this did not work either.

Are you having the fatal error when launching as well?

1 Like

Having the same problem here :frowning:

Unknown if it’ll help, as I am currently not able to access my machine, but disabling compression for a build does work, but it could increase file size.

I am also having the same problem :confused: I tried to zip my project

please let me know if you find a solution!

I was unable to find a solution. However, I realized that the fault was due to importing another project. After creating a new project and building my own stuff, I was able to build the project.

I’m getting the same error, but it doesn’t seem to be causing me any issues. The build still packages just fine, and runs fine too.

I have the same error,but it runs well???

Mine was solved about an week ago, I’ve uninstalled the MS visual studio including all of the “Windows SDK” files. Then I have installed it again (Visual Studio Enterprise 2022, version 17.2.1) with all of the sdk files including MSVC v143. Now it works fine no issues so far.
Check out the images: Imgur: The magic of the Internet
It seems to be reinstalling all of the MS Visual Studio stuff fixed the issue for me.

1 Like

thank you so much!

That doesn’t work for me, but from what I can see you have other workloads installed as well

This error is coming from RunUAT.bat in Engine/Build/BatchFiles. The script is looking for Intermediate/Turnkey/PostTurnkeyVariables.bat, but it doesn’t exist there (or anywhere in the UE5 file system). I’m not sure in what case you need this batch file, as I don’t use Turnkey to manage my sdks. In any case, this warning is happening because the script is wrong: you need to wrap the path after if EXISTS in quotes.

If you want to suppress this warning (which seems safe to do), at line 82, make this edit:

if EXIST "%SCRIPT_DIR%..\..\Intermediate\Turnkey\PostTurnkeyVariables.bat" (
	rem ## We need to endlocal so that the vars in the batch file work. NOTE: Working directory from pushd will be UNDONE here, but since we are about to quit, it's okay
	echo Updating environment variables set by a Turnkey sub-process
	call %SCRIPT_DIR%..\..\Intermediate\Turnkey\PostTurnkeyVariables.bat
	del %SCRIPT_DIR%..\..\Intermediate\Turnkey\PostTurnkeyVariables.bat
	rem ## setlocal again so that any popd's etc don't have an effect on calling process

I’ve been having the same problem with my project. I tried this solution but it gave me an unkown error and failed to build completely. I still haven’t attempted reinstalling completely the MS Visual studio as @AlexHeller8964 suggests. I tried building a new clean project from a template and that worked fine, so I’m assuming it is not a MS Visul studio problem, but something that has to do with my project? Any ideas on how to try to solve this situation?

My solution was to add to RunUAT commands this parameter

1 Like

(Sorry for the noob question, first time I’m dealing with something like this.) Would that be the RunUAT.command file, or the RunUAT.sh file? Also, could you please post a screenshot of where you place it exactly so I can try it as well? Thanks! :slight_smile:

I had the same issue, was solved by Ranisz solution. I didn’t add a parameter but I opened the BAT file itself and changed this line


That solved the issue

it doesnt work for me. i reinstalled ms 2-3 times and i installed literally everything but its still the same error.

1 Like

Where were you able to do modify that? I tried the uninstalling and reinstalling Visual Studio, adding all and some of the files included in the pic, but that did not work. After packaging the game, I do get the executable and the game seems to run fine, but I do want to try and get this error fixed. Thanks!

can you go into more depth with soloution??

how would you do that?