Download

The Livelink connection in the FaceAR sample project is not linking?

We have followed the instructions for setting up the FaceAR Sample project (https://www.youtube.com/watch?v=AIHoDo7Y4_g) and have everything running.

However the Livelink does not seem to be activated: the Windows 10 app does not show any updates the iOS app should be sending out.
iOS does detect the face and updates within the app.

-> Both machines are on the same network and should be able to see each other. (Check with a small setup using OSC communication)
-> Tried this in 4.20.3 and 4.22.1
Do we need to add any special rules to the (Windows default) firewall?

In the docs (https://docs.unrealengine.com/en-US/…ple/index.html) it says:
"Launch your Project, and in Project Settings set Supports AR to On."
Searched back and forth but I cannot find this setting in the project settings, can this be the cause?

Thanks in advance for any tips which will push us in the right direction towards a working setup.

(cross posted here https://forums.unrealengine.com/unreal-engine/events/1512398-unreal-engine-livestream-introducing-the-facear-august-9-live-from-epic-hq?p=1630367#post1630367 as I didn’t know where to place this)

For those ending up in this subject: one thing we found out: when the iOS app is build in 4.22, the Windows side also need to be running 4.22. A project running in 4.20 will not (properly?) receive any Live link input.

If you go on settings in the FaceAR app on the iPhone and choose the LiveLink connection, then with the correct ip-address, tap connect.

So, every time it doesn’t connect just tap connect again on the phone. I have to do it all the time.

Hello,Package successfully with 4.24, it’s not communicating with livelink on my PC,

  • Have you found a solution yet?

same problem

seems same problem :-(. have use windows cmd to ping my iphone, everything is ok, but i still cannot see any change in unreal project.

The problem is caused by the FaceAR app having no wireless data access. This might be a bug of iOS 13.

If you check your iPhone’s Settings->FaceARSample, there’s no Wireless Data entry.

When this happens, just disable Wifi on your iPhone, and relaunch the app. Then the app will ask for wireless access.

I’m having problems establishing connection / updating the face, after packaging. Works fine in-editor, 4.24.3. Windows

  • Matte Black Mocap’s “LiveLink” v. 1.2 app for iphone X

Questions I have asked myself:

  • Does it need to be packaged from a mac? Live link works with ipad for virtual cameras, so I suppose not. ??
  • Firewall? Made no difference.
  • Wifi? - Tried debugging by streaming a video. Task manager tells me that when connected in-editor, unreal sends about 0.2 mbit when connected to arkit. Build sends none.
  • Interference between build and editor? Tried running them seperately.
  • Tried “shipping” build configuration.

I’m not sure where to look next, so any input would be very appreciated!

Hello from NZ,
I was having a look around kiteboy face tracking demo, specifically FaceTrackingMap2 and Unreal Engine 4.25.3.

If you have the LiveLink Face app going and the map open in unreal - click window Livelink and you should see the readings coming through, but i couldn’t get the phone to drive the actor until i changed the name on the blueprint. So if your phone has a different name, Unreal doesn’t pick it up, mine was Als_iPhone… To fix this you need to go Content > KiteBoyHead_JointsAndBlends (double click) > Blueprint (Top Right Corner) > Move along to the first node graph (Live Link Pose) > Change Live Link Subject Name (to match your iphones name, found in the live link app settings >Live Link Subject name)

Or alternately you could just change your iphones name to match the unreal Editors iphone name.

Here’s a better link to that information i found after, doing it.
https://docs.unrealengine.com/en-US/…one/index.html

@Algillies hi,
@apelofff means the live link connection doesn’t work after the app packeged into a windows app.
I’m facing the same issue. Even play in a standalone game, the live link source can not be found.

**same issue
live link connection doesn’t work after the app packeged into a windows app.
Even play in game, and lanuch game. **