"The following modules are missing or built with a different engine version" with a new project


I was working on a project in Unreal Engine, and everything went fine until yesterday when I (as usual) switched to Visual Studio to edit some code, but when I switched back to UE window, I noticed that the compile button on the top disappeared. I restarted UE and tried opening my project but all I got was a message box with the following text:

The following modules are missing or built with a different engine version:


Would you like to rebuild them now?

If I click No nothing happens, if I click Yes, it shows the progress bar and after that another error message

StayAlive could not be compiled. Try rebuilding from source manually.

Rebuilding the solution in Visual Studio doesn’t help either.

I tried creating a new project in UE, but when I try to open it, it fails with the same error. I also reinstalled UE, but it also didn’t help. What can I do to fix this problem?

I installed Unreal Engine 4.10.1 from Epic Games Launcher and I also use Visual Studio 2015 Community Edition which was installed when I first created a C++ project. I am able to open Content Examples project or a fresh project which was created from a blueprint template project, but the UE window doesn’t have the Compile button on top (I guess because these projects don’t have any C++ code).

The version from Help > About: 4.10.1-2791327+++depot+UE4-Releases+4.10

So it successfully build in VS?


  • What errors are you seeing when you build the project in Visual Studio?
  • Have you seen this error in the 4.11 preview? If you haven’t tried, could you please give that a try?
  • You’ve been able to successfully work in the engine using VS 2015 up until this error occurred?

Yes, it does.


  • No errors, it builds succesfully.
  • I haven’t tried 4.11 preview, I’ll try it now.
  • Yes, everything was fine before, the problem appeared yesterday.

Definitely let me know the results of the 4.11 test.

When it builds successfully in Visual Studio, are you then able to open the project?

No, I still get the same error.

Tried it with 4.11, the problem still exists unfortunately. I also tried reinstalling VS 2015, didn’t help.

My project has also suddenly broken with the same error. I downloaded 4.10 on Tuesday and created a test c++ project based on the FPS template.

I have come back to it today and it builds fine in VS2015 Pro but then when it launches it says UE4Editor-Helicopter.dll is missing or build with different engine version.

It asks if you want to rebuilt. Press Yes and it says "Helicopter could not be compiled. Try rebuilding from the source manually.

Tried a clean/rebuild all of solution which was successful but still get same error.

Thank you for the information.

Have either of you been able to run the editor in debug mode through Visual Studio?

Also, could you try right-clicking on your .uproject and selecting the Switch Engine Version option? You can choose either 4.10 or 4.11.

When I run the DebugGame Editor configuration is VS (is it what you meant by run the editor in debug mode?), I get the same error, only difference is that the dll name is a little bit different (with -Win64-DebugGame appended).

What do I need to do after switching engine version? Do you mean I need to create the project using 4.10 and then switch it to 4.11 and open it in 4.11?

What you need to do to switch engine version is go into the folder that your project is located in. Then, find the .uproject file, right-click on it, and select Switch Engine Version. A window will appear asking you which version you’d like to switch to. Select either 4.10 or 4.11, and then attempt to open the project again.

It seems I finally fixed the problem when I added the Unreal Projects folder and folder with the engine (4.10 and 4.11) to antivirus exceptions. I’m not sure what exactly my antivirus did, but now the editor window opens and I can edit my project. I have Avast in case it helps.

I also had this issue until I added my project folder to my Avast “File System Shield” “Exclusions”. I noticed that the .dll file was being successfully built by Unreal, then was immediately disappearing, and that was because Avast was deleting the .dll file.

I also started getting this error today. I have added Unreal and MyProject folders to MS Essentials Exclusions but I am still getting the error.

1 Like


Have you attempted the various suggestions offered in this thread? If not, go ahead and try those out and let me know if it works.

Also, there was recently another user who was reporting a similar, if not the same, issue. Take a look at their solution and see if that helps you: Error in creating a C++ Project - C++ - Unreal Engine Forums

Hey Sean,
Yes, I tried those solutions.

I tried uninstalling Unreal 4.10.2 and reinstalling. I received an ‘instal’ failed error. I restarted, and tried again and it verified, then installed with no error, but I still get the same dll issue.

fwiw - I didn’t have VS installed and I wasn’t using it until I read up on this issue.

Do you currently have Visual Studio 2015 installed? If so, did you ensure to enable to C++ content? The necessary C++ and Common Tools content does not come with VS by default, and you must manually enable it within the installer in order to get what you need to run the engine.

Yes and yes.

Can you specify exactly which files you created exceptions for with your antivirus? It’s possible that a file may have been overlooked.