The developers of the engine, the description of the bug and a possible solution

What makes you think it a bug? No body reported similar issue and assertion errors can be caused by errors in your code too

I assume you code C++, do you create any object or asset? this condition fails when this codes meets object (in package i assume so it is kind of suggests its a asset) without set outer

I came across a serious bug with the engine crash when connecting the client to the host. I don’t know what it’s about yet, but there’s a little research.
The bug is that when the client connects to the host, it immediately throws it into the code (Engine\Source\Runtime\Engine\Private\PackageMapClient.cpp, line 681)

I tried to fix this bug in different ways, but I do not have time to dig into the engine code, so I decided to fix it in my own way :smiley:
I know that “check” throws in the engine code with a negative result, so I just did so

It really helped, but I do not know how it will affect the stability of the engine and the project. But no more crashes.
And the MOST IMPORTANT thing that I was able to learn that helps duplicate cards. And not just make a duplicate of the existing, and create a new map and copy everything from the old map. It really helps! But in this case, completely lost vegetation on the map and have to use “crutches”.

Dear developers, I am ready to assist as much as possible if something is required from me. I’m using a build from GitHub 4.21.1

I apologize for my English, I am not a native speaker :slight_smile:

Yes, of course I create objects in the code, but how can I explain that a duplicate of the map allows me to fix it?

And I have some maps. On one map everything works perfectly, and on the other crash. At the same time on both maps identical logic and all objects.

I’m sorry, can you download this map and try running version 4.21 on two clients?
There is absolutely empty, nothing, but if I run the game in 2 client (server and client), then there is a crash.