The degenerate tangent error message.

Is there a way to disable the ‘‘degenerate tangent bases which will result in incorrect shading’’ message when you import meshes? Because when you have 500+ meshes to import and about 1 out of 2 require you to close the dialog box to continue the progress, it’s irritating. Thanks

I am also interested in this matter. I had to press ok for almost 900 meshes…

Hi Heartlessphil and AereVoS,

Degenerate Tangents are due to the UVs not being setup properly to be in-line with MikkTSpace tangent basis that was implemented in 4.7.

My post in this AnswerHub question can help you understand why this is: Degenerate Tangent Bases - Rendering - Unreal Engine Forums

In 4.8 we’ve exposed in the Static Mesh Build settings for the option to disable MikkTSpace, but this won’t solve your issue when initially importing as you would still get the warning about degenerate tangents.

You can by-pass this though by opening your ConsoleVariables.ini file and putting in the line MikkTSPaceOptional=0

This will disable MikkTSpace when importing as it is on by default.

I hope this helps, although I wouldn’t recommend this and would encourage setting up UVs to get proper results.

Tim