Textures too bright, am I missing something?

Okay I seem to remember having this problem before, but I never wound up finding a fix for it. I’m at a point where it needs to be fixed. I’ve looked around and tried the sRGB checkbox both on and off in the texture editor as well as changing from color to linear color and back in the texture sampler. When I have sRGB unchecked and linear color enabled it shows the right color in the thumbnail but then the wrong one in the texture sampler and level.

I assume I’m missing some small detail. Problem is that I’ve searched and people just mention switching to 8 bit textures to fix it or just fiddling with the sRGB and linear color/color settings. I’d like to not have to reformat all my textures to 8-bit because I have a lot that I’ve generated so if there is another way I’m all ears.


1 Like

Hello JoshieZombie,

You could try checking sRGB to true inside of your texture editor.

Changing to an 8-bit image is the tried and most effective method for fixing this issue.

If you are looking for a quick work around, there is also the option :

1.Create constant vector

2.Add multiply Node

3.Add your Texture sample into the A of your multiply node

4.Add your constant vector to your multiply node

5.Plug that into your Base/Diffuse Channel

For more control after the multiply node add a clamp node and set the min to 0 and max to 1 ( This will set a value that cannot be exceeded for any values higher than 1.


1 Like

I had the same issue. Exporting the textures as .tga files solved it for me.

Thanks, I was trying so hard to solve this issue, the only thing that worked, was saving the texture in 8-bit.