Textures reacting crazily with ArchiCAD model

Hi all,

I am a newbie in UE and currently still learning as i am working on a project so bear with my newbie question aye…
The model i got from my office (where everyone uses archicad) finally got exported into UE4 successfully in the obj format. However, the scales of textures seems off when i tried to dump in a default starter pack material. So i added a textcoord function to the material (from guides) to scale them off. Finally, i got the scale right but then the whole tiling seems to be abit crazy.

Some parts of the tile seems to be off scaled and some seemed to be overly stretched as you can see in the attached model. I am suspecting that UE4 is not ArchiCAD friendly and thus not reading the exported surfaces correctly. Is there a to workaround this problem rather than remodelling the entire thing? (i believe no one in my company is willing to do that for me =()

Thanks for your help in advance!


Hello MK, the model is fine, but you did not (or not properly) unwrap the UV’s for the model.
I dont know how to do this in archicad, but I expect a good google search will give you the result you need.

Thx Luos for the reply…I thought so too.
I converted the model to Fbx now and tried again. the mapping got better but there is another problem bugging me.
I just cant create another uv channel using UE4 … nothing happens when i hit the apply changes button. the uv channels still stays at 1, and on the uv channel dropdown there is just 1 channel > UV channel 0.

Already answered your other post (one problem per post, then accept it)
But if you dont have a proper uv-map the generator can look at, it cant generate a proper uv map.

Also, that mesh will never work in the engine, cut it up.
think of ue4 as a set of legoes. make small pieces. i suggest you follow some tutorials and look at how other people made maps. making one giant mesh just wont do.

hi! Fixed the problem? Any software recommended to make the process of fixing uv maps?
You are not alone here lol