Textures not importing correctly

I cannot get my textures to import correctly anymore.

Early on I learned that textures become washed out if you try to use .PNGs.
Supposedly disabling sRBG would fix this, and indeed it does cause the texture itself to look right, but the material then requires it to be set as a Linear Color to work, and setting it to Linear causes the material to become washed out instead with the same end result.

I used to be able to get around this by just using .TGAs instead of .PNGs, but I’ve now noticed that the .TGAs have horrible artifacts, like it’s been very badly compressed. I don’t think this used to be the case, but maybe I just never noticed.
This must have simply been a longstanding oversight of mine, because I’ve tested the same texture in both 4.21 and 4.8 with the same issue appearing.

I’m using Substance Designer to make them. They look fine inside Designer obviously, and they also look fine if I open the exported textures in Photoshop. They only get botched up when I import them into UE4.

Here’s an image of the issue I’m having;

How do I get around this?

One way I’ve found is to use a .TGA, but change the compression type to BC7. The problem with this is that it makes the file size roughly 10x as large, and doesn’t seem like the best solution. Somehow, the file size is actually roughly double that of the original .TGA before import with BC7.

Also, while adjusting compression settings, the texture will sometimes randomly decide forever that it needs to be set as a Linear Color in the material just like a .PNG, causing it to become severely washed out. As far as I can tell, only deleting and reimporting the texture can correct this.

perhaps this will solve your issue:

Not really. The only conclusion I found there is that 16-bit textures don’t work with UE4? But I’m pretty sure Substance Designer defaults to 8-bit.
I tried forcing it to 8-bit anyway, and the issue remained.

I’ve searched thoroughly through posts of similar issues beforehand, and they all seem to give one of a couple answers; use .TGAs, which is creating compression artifacts, or use 8-bit .PNGs without sRGB, which has failed to fix the washed out colors in my testing.

It should be fine if you put the 8 bit png in srgb.
you basically only need to set it to 8 bit rgb is its a grayscale texture.