textures have gone blurry

I upgraded to UE4.4 recently and just noticed that so many of my 2048x2048 textures that were created in Zbrush have gone all blurry. Some of my other textures are fine. Some that I created in Zbrush are fine. But most, around 40 of them, have gone all blurry and now my game looks terrible. Here is an image:

You can see in the game it’s making the characters look terrible but yet that little table you can see in the corner is fine. There is no detail in any characters. I have the image opened in photoshop on the right and you can see that there is a lot of detail and opened in ue4 on the left, it is super blurry. I’ve tried rebuilding lights, reimporting the images in a lot of different formats…this must be something easy, some box I have unchecked or something? it’s driving me crazy. Any help much appreciated.

1 Like

Go into the texture editor and make sure you have a proper MipMap Generation setting.
It will be under the Level of Detail settings.

It looks like you have it set to FromTextureGroup, try none and see what happens.


Or you can go under the Texture settings,
click the drop down, and change the Filter.
Try nearest neighbor or default under that.


1 Like

Thanks for the answer!! Worked like a charm on my project :smiley:

Wow, this happend to me when I migrated my project from 4.12 to 4.13. Thought it is a migration problem. This post saved me alot of time/work!

This even helps with render targets when you need the pixels to be precise. Changing the filter to Nearest did the trick.


1 Like

Still doesn’t work for me. I use extremely low resolution textures (32x32 in this instance), and there’s always blurring. Completely impossible to turn off in UE, as far as I can tell. The texture preview becomes sharp with filtering set to “Nearest”, but it combines a lot of pixels into single color blocks, and the result on the model is still extremely blurred.

Right click the texture in your content browser and
Sprite Actions > Apply paper2D Texture Settings

Set Filter and MipMap settings as needed.

That helps a lot, but there’s still some mipmap-blurring, and pixels are still combined into single color groups


Your compression settings are still set to default, it needs to be UserInterface2D

1 Like

Oh, that actually worked! Thanks!
There is still a little bit of mipmapping going on, though.


I’m not entirely sure what to do about that since I don’t have a similar model to test on. Looks more like a shading issue on the model than MipMaps to me though.

How can i mange this with a media texture?