Download

Textures from blender not saving on mesh

I made a quick 1 min video as it will be easier for you to watch rather than me try and explain it.

https://www.youtube.com/watch?v=WeIJ-4-k9v4&feature=youtu.be

Basically when i export/import these rocks i made in blender to UE4, the rocks import no problem but the textures on the rocks are gone and im just left with some white rocks.

Please help :frowning:

You need to export your texture maps separately.

How are you texturing the rocks in Blender? I assume using a texture. If so find that texture and import into UE4 then setup the material for that asset.

How do i do that?

also make sure you use an accepted file type for you textures, i’ve heard that UE4 now takes jpg’s but i haven’t tried i always use tga"s

From what i understand i can save the actual rocks and then save the textures that have been applied to the rocks?

So, how do i go about saving the 2 separately from each other?

Yep :slight_smile:

rock -> export it as a fbx
texture -> go into your uv editor and save the texture as a tga/png/jpg

After that import everything and do a right click onto your texture - create material - assign the material to your mesh

2f3d5b4e91efc9d57bb9a56fcb9211c7b1732834.jpeg

When i try and import the textures to UE4 its saying “The texture you are importing is not a power of two. Non power of two textures are never streamed and have no mipmaps”

I tried saving as all 3 file types you suggested and still i get that prompt.

By the way, i made these textures using a combinations of nodes inside blender, they arent just normal textures.

I got it to work, had to change it to Texture paint to get the texture on the rocks to appear in the UV/Image editor>

Thank you for your help!

that neams you need to save your texture in correct size like 1024x1024 or 2048x2048 etc

you can bake procedural textures to a bitmap ising options in render tab (blender internal or cycles)