Textures extremely dark for some reason

So I decided to make a quick metal wall texture in painter to experiment with the texturing tools in UE4 but for some reason this wall I made is really dark compared to what I thought it would look like. Here is what it’s like in painter and what it actually looks like in the engine:

Why is it so much darker in-engine?

Do you have a reflection capture affecting that mesh? Metallic materials get their color from reflections, without any reflection source they go black.

I don’T exactly know if this solves your problem, but maybe try to disable SRGB on your maps with grayscale (Metallic, Roughness, Height, ORM).

Tried playing around with reflection capture but it made barely any difference.

How do I do this?

EDIT: I decided to increase the roughness of the texture somewhat and then it became considerably more visible. That doesn’t actually solve the issue however because the texture is suppose to look metallic.

EDIT 2: I did a second experiment where I increased the metalness again but also brightened the color to a more grayish color. This also helped a lot. I think it’s the combination of high metal value with low roughness value and very dark color that is making the texture not very visible. Is this just normal after all?

If you have a metallic surface, it becomes completely reflective, therefore diffuse contribution of the lighting has very little effect and the material is lit entirely by reflections, whether they’re direct from dynamic lights, indirect from reflection captures, or SSR. If your Albedo for your metallic surface is below the average value of metals(180 sRGB), then you’re going to have a metal that is too dark in general regardless of lighting. The same concept applies when your roughness is low, because the surface becomes more reflective, although the specular vs diffuse contribution varies with non-metals.

@rosegoldslugs I started to follow you on Artstation you have some very impressive stuff there.

I never thought about the effect of metals below 180sRGB, I hope that doesn’t make me
a bad 3d artist, anyway, I am using Substance Painter and Quixel with some other software and maybe thats why I never had this problem.

@splattenburgers You sometimes have dark (black) materials in unreal when you use SRGB on grayscale maps like metallic, roughness,
height, opacity and so on. With SRGB sometimes (often) Unreal masses the Material up, so I always turn that off for grayscale maps.

You can turn it off in the edit mode of a file, so I mean when you import a map using grayscale, double click on it.
On the right tab menu you should see a tick at “Use SRGB” or something similar. Untick it and then press save (in the window).

In the material you then need to use “Liniear Color”, unreal should change it on its own when you drag and drop the map file in the material window
after doing the previous step. If not, it is on the left tab menu when you click on the map file in the material view.

I guess there are some reasons to not do it that way, in general when you want to use SRGB for a specific object, but for
me it always works and it shows the way I want.

Kind regards,
Toby :wink: