Download

Textures blurring in UE4, resource size showing as 3kb

I’ve run into an issue today that sort of came out of nowhere. Two of my most recent diffuse textures are permanently blurred in the editor. The resource size is showing as 3kb, when it was much larger than that upon being imported. Nothing seems to fix it except deleting the texture and re-importing it (the right click - re-import doesn’t work) and that is only temporary as it repeats itself. Has anyone else run into this issue, or know of a solution to it? Any assistance would be greatly appreciated. Thanks!

if someone else has the same issue you just have to enable Never Stream parameter in the texture editor

thanks a ton!

Anyone knows why do it happens that? With the Never Stream parameter not happens, but it isn’t a solution, I want import any texture without check this parameter. I tryed removing the delivered Data Cache folder, intermediate folder and saved folder with the same results…

I’m afraid I don’t know and you might not find your answer because Unreal texture streaming is a mysterious beast. I’ve seen many finished commercial Unreal games with messed up streaming so if even the big boys can’t figure it out then it’s no piece of cake. But I hope someone comes along with a solution for you!

r.streaming.poolsize 1500

Try typing that in console… Maybe u dont have enough of a pool size and it streaming based on what little it has by default. You never want to say never stream… thats dumb… There is also an option in texture settings for individual textures to decide the level of mip map and stuff… for distance.