TexturePacker Creates artifacts on import

Hello,

I would like to report that Texturepacker and UE4 do not work in harmony creating horrid artifacts that in my case have destroyed most of my game.

All packed sprites when using bi/tri-linear on the texture filter settings take the color properties of the closest to them packed sprite on its edges regardless of the options i set inside Texturepacker(Extrude,Border Padding,Shape Padding .etc). If you know any setting that would cure that i would be grateful.

I can send you the files on request via P.M so you can see it for yourselves.
This is a HUGE problem for any paper2d project and until it is resolved it renders (pun intended) my game as a no go! I also have rendering issues with flickering when nearest is enabled but one thing at a time.

Please notice that in the texture that has Bilinear activated you can see the artifacts.

Thank you.

alt text

Hey Roccinio,

Can you reproduce this using a normal sprite not exported from Texture Packer?

We need to eliminate which one of these is causing the issue. The exporting from Texture Packer or the Importing and compression within Unreal. If the ‘Nearest’ filter is not producing the results you are reporting, then we have to test to see if it occurs with a regular sprite not exported from Texture Packer.

Let me know your results.

Thanks,

Andrew Hurley

Hello,

No this is not happening when i import the png by itself (or any for that matter). Having said that if i create a TexturePacker export with only the sprite in question the this is not occurring as well.

The problem is happening when you pack more than one png with TexturePacker (the reason we use TP). Unreal fails to distinguish between packed sprites and takes the borders of each sprite and adds them to one another creating artifacts. Please notice how the chest inherits the colors from the rainbow sprites next to it.

I have to assume that this is a UE4 problem because the texture that is exported from texturepacker is correct with no artifacts. The artifacts are added when i change settings from within UE4.

Cheers.

Would you mind sharing with me one of your test packed sprite sheets from Texture Packer so I can test this on my end?

Thanks,

Andrew Hurley

I have send you a P.M with the files requested.

Cheers.

This is not on this specific texture sheet. It is for ALL sheets exported from texturepacker.

I would partially agree with you that this would be an non issue if it occurred for single sprites as well. If you import the single chest png that i gave you and set it to bilenear it does not create any artifacts, does it? Then why it does so on every texturepacker export? This is not standard and expected behavior.
You are literally telling me to import all pngs one by one if i do not want artifacts.
Is that not a bug?

And yes there is a reason why we need bi linear for 2d games especially when you change the FOV. Without it everything appears pixelated and flickers.Also some games benefit from the “soft” look.
Also if you do not use bilinear there is another issue with unreal that makes rendering jittery. But more on that on another report.
I need to see this fixed before i go any deeper.

Please test the single png example i gave you and if it does not create any artifacts when using bilinear please report this as a bug because it has destroyed my game.

Thank you.

So this does not appear to be a bug, but just the outcome of using either the Bilinear or Trilinear filter for this specific texture sheet. I do not see this ‘color bleed’ using the Default (from Texture Group) settings or using the Nearest Filter. Especially if these artifacts do not appear in other textures using the same filters.

Unless there is a specific reason you have for using Bilinear or Trilinear filtering for this specific texture sheet, I suggest staying with the Default filter as it produces the correct results.

Thanks,

Andrew Hurley

Can you export the same sprite sheet from a different program and get the same artifacts?

Do you use/have the Pro version of Texture Packer?

I am not telling you to do anything aside from what I said in my previous post. I am simply trying to understand the reason for using Bilinear filtering which introduces the artifacts, instead of the default texture filtering settings.

I have the pro version.

What i was saying earlier is that us paper2d guys need the bi linear options. It is not a gimmick. It is vital for our games.
Another reason has to do with texture compression. We simply cannot use the uncompressed method because of the texture size that is 16.5mb for a 2048x2048.
With that setting we wouldn’t need anything but the “default”, but we are forced to use the default compression of ue4 resulting in great quality loss. The only way to “win” back some of that is to use bi linear.

To summarize it. We either run out of VRAM or we use bi linear to hide some of the artifacts that compression creates.

Now do you understand why it is super important to fix this issue that is created ONLY by texturepacker and not by importing one by one the sprites of that texture sheet?
I really do not understand why you see no problem with my report.
I have send you the files. You can recreate it and you can see it happening.
90% of my game has artifacts that shouldn’t be there. We have created art that looks terrible because of this problem.
TexturePacker is officially supported by UE4. You even have a tutorial on how to use it.

What else must i do to prove that this is a game breaking bug for any Paper2d project?

Hey Roccinio,

I was able to confirm what you are reporting and have gone ahead and entered a bug report for the issue. You can track the issue following the link below on our new Public Issues Tracker.

UE-35103

Once the issue has been addressed by our engineers, the fix will be added to the release notes for fixed issues within an upcoming full engine or hotfix release.

Let me know if you have further questions or need additional assistance.

Cheers,

Andrew Hurley