Texture UV interpolation jagged without Nanite

Hey there, this is my first question here. I imported some FBX geometry with textures that looked nice and smooth in Maya into UE 5 and with Nanite enabled, it looks nice as well:

But with Nanite disabled, I see some UV texture interpolation artefacts:


Is this a known issue? Maybe related to per-pixel vs. per-vertex calculations? I could not find any setting on the material or texture that would fix this.
Thanks, Michael

Try using the Vertex Interpolator node on your texture coordinates. That should force them to be calculated in the vertex shader to test that theory. You can also test enabling “Full Precision UVs” but it shouldn’t be needed for most assets.