Download

Texture/terrain quality problems in the packaged build

Feels like one I should work out on my own, but I’ve been scratching my head on this one for a while.

While the levels in the editor play through great. When I run the game directly (after packaging it), some of the textures (big ones) and terrain resolution (I surmise that terrain height is run from a texture, since lowering texture quality seems to cause the terrain to render differently) render poorly.

It appears to be mostly picking to a very low resolution for the texture, but it’s worse than anything I can get with the scalability settings. But it also seems to be very fragile. Occassionally when moving the camera around, the textures and terrain will pop to hires and then go back, which suggests something related to the LOD calculation.

Calling “Scalability::SetQualityLevels”, whatever I set TextureQuality to, doesn’t improve the way the textures resolution (it does affect other render quality, so I’m confident that I’m changing the scalability levels). Are there any other quality/texture related controls I’m missing?

This happens in my more loaded levels, so may well be I’m maxxing out my texture budget… but this doesn’t seem to be the right symptoms for that.

Anyway, I know it’s a long shot that anyone out there’s gonna have seen the same things I’m seeing, but thought it was worth asking… Hoping for some common problem when switching to Packaged, or some configuration or setting I’m overlooking.

In editor, looks as it should (sorry little dark… turned my light down for some reason):

Same spot, running packaged – terrain rendering heightmap gets very low res, where collision stays hires, so here the feet of the player and the rock he/she was standing on are covered by the crudely rendered terrain
(sometimes the terrain texture and rock’s texture go low res as well, harder to repro)

In editor, starscape looking good:

Run Directly, textures defintely seem lower res… I’m not sure what that purple is… is the texture actually dropping transparency or is that just an artifact of the low res’ing?

-set you scalability settings to “epic” + package your game again :slight_smile:
-those low res textures from the landscape could be caused by your mip maps -> change the texture streaming distance https://answers.unrealengine.com/questions/12910/bug-mip-map-are-too-brutal.html

Thanks for the suggestions!!

I actually had two issues.

I must have been max’ing out my texture pool. Calling “ConsoleCommand(TEXT(“r.Streaming.PoolSize = 2000”))” fixed it. Now I’m wondering if this means I need to cut down my texture usage dramatically. (BTW, calling SetQualityLevels will set the PoolSize so you’ll need to override the pool size everytime you change Quality levels)

I also included pictures of starfields that looked terrible. This was actually unrelated to the texture pool. This was autoexposure settings at different Quality levels were giving me dramatically different effects.

(Forgot to credit this thread for the poolsize answer: https://answers.unrealengine.com/questions/248079/landscape-at-low-lod-in-standalone-game.html)