Texture stretching instead of tiling.

Hello Answerhub Gurus,

So I was working on a level blockout last night and thus I decided to import some dev textures I made a long time ago. I then proceeded to setup a [very simple material][1] that I could use, and everything worked just fine!

However today when I went to open up my project, all the textures are stretched in some really odd ways and I have no idea of what’s causing it. When opening another project, everything works fine, so it’s something to do with this particular project, but I can’t pinpoint it.

Here’s a screenshot I took last night:

And here’s what it looks like today: (Don’t mind the slight adjustments I made in the meantime. Everything worked last night!)

Lastly, here’s the floor of the First Person Template example map:

As a side note, I’m running the latest version of UE4. (4.4.3)

Thank you in advance.

Kevin Østerkilde.

1 Like

Hi ,

How do you have the material set up in the editor? Additionally, what is your UV setup like?

The material is just a basic one, nothing special at all.

The UV’s doesn’t matter, it does this on every model it seems.

Hi ,

If you are comfortable with it, would you mind sending me your .uasset so I can have a look at what may be occurring? Thank you!

Hey ,

I was wondering if you were using BSP brushes to create your geometry because if that is the case, you can select the individual faces on your walls. Select the alignment drop down box and choose the planar option. This will align your material to the surface in a planar fashion. Along with that you can also scale, rotate, and flip, the material so you can get some good variations if needed. Be sure to lock the scaling parameters so they scale uniformly! I hope this helps, but let me know if you are still having issues.

Here is an image to help you locate my directions:


It happens on meshes too. Besides, I already tried your suggestion, and it didn’t do anything.

However I just opened the project again, and now the orange walls and the grey floor are fixed, however the material instances/textures for the windows and door are still messed up. No idea why, and no idea what fixed the other two.

No problem at all, however the connection speed I’ve got here is a little sloppy, so you’ll have to wait until tomorrow, as I can go to a place with a much faster upload rate.

Sidenote, the orange walls and grey floor suddenly fixed themselves. No idea why, I haven’t touched anything. The material instances/textures for the windows and door are still broken though.

Try recreating a new material instance since now the stretching is somewhat resolved. Let me know if this fixes the issue.

Just tried that. When using the grey and orange grid textures, it works fine. However if I use the window/door textures, it gets messed up, so it doesn’t have anything to do with the materials, but the actual textures. I have no idea what is going on though.

Here you go, these should be all the files you would need.
link text

Looks like you’re clamping your texture. In the advanced Texture settings, make sure you have your X and Y tiling method set to Wrap instead of Clamp.

1 Like

You are my hero! Although I’m fairly sure I didn’t set them to clamp. Oh well.

At first after changing them, the windows worked, but the door was still messing up. Had to change to another material and then back, that fixed it. :slight_smile:

Now I can finally block out some more stuff !

Yeah of course. Anyway, the solution was posted below. :slight_smile:

Are your texture images for the window and door a power of two? For example 256x256 or 512x512?

Glad to hear you found the answer!