Texture Streaming Pool Over

Have this problem in 4.9 and 4.10

Project was working fine now every time I launch the game I get a TEXTURE STREAMING POOL OVER 65.5 mb and so on. Textures pop and blur out in the scene.

How do I deal with this?


Hello Johnny Galvatron,

There are a few console commands you can enter to see where your texture memory is being allocated. Try bringing up the console command window and typing ‘Stat Streaming’ to visualize your project texture memory counters and streaming capacities.

I will say that using the ‘r.Streaming.PoolSize’ and increasing the number there will definitely help.

You can also follow the link I have provided to get a more in depth look on how to troubleshoot your streaming and non-streaming textures.

Texture Streaming

If you have further questions or need additional assistance please let me know.



Thanks Andrew! Worked a treat.

To get to the console command window press the tilde key (next to 1).
That would of been helpful in the answer for those of us who don’t already know how to get the console command window up.

So I get the console command up type it in and hit enter, but the console command bar just disappears and there is nothing to adjust?

You need to set a number in a value of MB after typing the console command. Something like ‘r.Streaming.PoolSize 2000’

Read the documentation I provided in my answer for a more in depth explanation on streaming textures, and how to troubleshoot your own projects texture issues.

Thank you,

Sorry to bump this question but just to be sure: I’m working on a desktop project and packaging the project I’ve read the warning (I was about “over 860/400 mb”): I had already added the string "r.Streaming.PoolSize=4000
" under the paragraph “[/Script/Engine.RendererSettings]” in my DefaultEngine.ini , and running the project packed doesn’t seem to have visual issues/problems, but since I still have to add objects (and overall I have to tweak the DefaultLightmass.ini ) I’d like to know if I added the string correctly or I have to write it somewhere else! Thanks for all in advance!

As long as you are not seeing the error message after changing the setting within the .ini properly, then you have done this correctly. If you begin to see this message in future iterations, I would take a look over the ‘Texture Streaming’ documentation. It has a lot of good pointers and tips on how to troubleshoot texture streaming issues :slight_smile:

Hi ChrisBradwell,

could you also mention about what to do after pressing tilde key? Because there isn’t any line or space for writing commands. It says 0:NavMesh, 1:Basic, 2:BehaviorTree and so on. Where to enter commands after opening console with tilde key?

Hello ,

After pressing the tilde key, you simply begin typing your console command. In order to understand what certain console commands do and when to use them, I would take a look at our [Command Line Arguments][1] documentation.

You can also type most console commands followed by a question mark which will provide you with a quick definition and its current set value where applicable.

One more thing, which I tend to do with each new full engine release, is use the ‘DumpConsoleCommands’ argument. This will dump all the console commands into your Output log (Window > Developer Tools > Output Log). You can then copy them into a notepad and easily search for commands when needed.

Let me know if you have further questions or need additional assistance.


Hi there!

This may be a silly question but does increasing the Streaming Pool Size in the console command permenantly increase the limit or is it only a temporary solution.

Also, is there a way, maybe through blueprints, that the engine can clear the texture pool between loading maps. Often in the Editor, when I load multiple maps the texture pool limit is quickly exceeded.


Hey ,

Increasing the Texture Streaming Pool Size either through the console command or the .ini file settings will keep your settings whenever you restart. If you want to verify this is the case you can open your Output Log and enter the console command ‘r.TextureStreamingPoolSize ?’

This will give you information on your current setting as well as the quick definition of what that particular console command does. You can add a question mark to the end of most console commands and there will be a brief definition.

There should be a console command which you can use to clear cached or saved textures from previous maps. This is usually handled automatically, but if you enter ‘DumpConsoleCommands’ you will get a list of all console commands. You can search through those to find the appropriate one.


Thank you, Andrew. That’s very helpful! I appreciate it.

You need to \Engine\Config\ConsoleVariables.ini increase inside,
And restart the engine,


Start the engine, in the output log will see if there were any modification.


Hey Andrew,

Thank you very much for all the information.

I have one more for you if you don’t mind. What’s the drawback of increasing the Streaming Poolsize ? I assume the default value (1000) was set for a reason. Would there be any issue/instability/crash for doubling it ?

Hey Genova,

So overall the texture streaming system, or streamer, is the part of the engine responsible for increasing and decreasing the resolution of each texture. This enables you to have good visual quality while managing the available memory effectively.

When you increase the texture memory pool, you allow for a larger amount of textures to be loaded and streamed in and out of memory. If this pool is too large, or exceeds the VRAM of your GPU, then you can quickly overload your GPU’s memory and cause it to drop in performance. This is why the default is so low, to account for lower end GPUs with less memory.

It also depends on the size of your textures, LODs, Texture Groups, and biases. All of these settings can help you find the correct texture pool or adapt to your current one in case you cannot increase the overall pool size due to hardware limitations.


Just as a heads up for anyone else who might be in a similar situation as I was. I got this warning after adding a whole lot of foliage to my level and re-built everything. While painting the foliage, I had the cull distance set to 0 so I could see all of the trees from high up in the air. As soon as I set the foliage max cull distance to 40,000 the error message went away.

On UE 4.14.1 this method dont work, now to increase your streaming pool size by default you need to go to C:\Program Files (x86)\Epic Games\4.14\Engine\Config\BaseScalability.ini scroll down and you’ll find the secction with TextureQuality@0, TextureQuality@1, TextureQuality@2, TextureQuality@3 and TextureQuality@cine ,(every secction has its own Poolsize value) in my case, my pool size was set by default to 1000, so i identify that seccion TextureQuality@3 got pool size value to 1000, so i change it to 2000 and save. thats all.

To change the Pool size inside the engine(Running EU4) open console and type r.Streaming.PoolSize _2000 (IMPORTANT!!! between the e letter of Size and the Low line must be a space)

Thanks it works like a charm

I tried to increase the Pool Size manually, few minutes later my graphic card crashed and I had to rollback the drivers to a previous version. I’m not so sure that this is the best solution.