"Texture Streaming Pool Over 430326.19 MB"

When I launch my game on my iPhone 4s, I get an error that says “Texture Streaming Pool Over 430326.19 MB”. When I tap Play Game, it loads the first level then “crashes” back to the main menu. This continues to happen every time I press Play Game. However, if I run it in the Mobile Preview on my PC, it works fine and does not error.

This only seems to occur when I use a widget that contains a slightly transparent button that covers half the screen. I read somewhere that transparent images cost a lot on mobile. If this is the case, are there any alternatives to using my button? Would it be better to use a PNG of the button instead of making the background color of the button itself transparent?

I have attached my [iOS log][1], in case that is helpful.

Any suggestions?

Update: I tried skipping the level with the transparent button and that didn’t help. I tried removing in the background from the screenshot above, and that didn’t help either. I don’t know of any other textures in my entire game that could be affecting the streaming pool. Any suggestions?

Update #2: I can get past the ‘crashing’ issue by starting on a different level other than the main menu, but as soon as I try to switch levels, it jumps back to the main menu. It also shows the “texture streaming pool” error no matter what.

Update #3: I tried launching it on my PC instead of just doing the Play options, and while it didn’t give me the Texture Streaming Pool error, it ‘crashed’ back to the main menu every time I clicked Play Game.

LogPlayLevel: UE4Game: [2016.01.31-19.45.47:191][829]LogNet:Warning: Travel Failure: [InvalidURL]: Invalid URL: /Game/Demo/Maps/MainLogNet:Warning: Travel Failure: [ClientTravelFailure]: Invalid URL: /Game/Demo/Maps/Main
LogPlayLevel: UE4Game:
LogPlayLevel: UE4Game: [2016.01.31-19.45.47:191][829]LogNet:Warning: Travel Failure: [ClientTravelFailure]: Invalid URL: /Game/Demo/Maps/MainLogLinker:Warning: CreateImport: Failed to load Outer for resource ‘WidgetTree’: WidgetBlueprint /Script/UMGEditor.Default__WidgetBlueprint
LogPlayLevel: UE4Game:
LogPlayLevel: UE4Game: [2016.01.31-19.45.47:205][830]LogLinker:Warning: CreateImport: Failed to load Outer for resource ‘WidgetTree’: WidgetBlueprint /Script/UMGEditor.Default__WidgetBlueprintLogOnline:Warning: NULL: Can’t start an online game for session (Game) that hasn’t been created

Regarding the ClientTravelFailure error, that appears to be something entirely different, and the solution is found here: https://answers.unrealengine.com/questions/196214/failed-to-load-package-on-client.html

“The “Launch” button in the editor will only cook the current level that’s open and save it in the Saved/StagedBuilds directory, which could explain the travel failure. One more thing to try is using the Package Project option. This will cook all the levels in your project, and should allow the server to travel to any of them.”

I get the same error on my Desktop project…i simple removed the option “texture streaming” on project settings, rendering section

This solved my problem.