Download

Texture Smeared/Stretched along edge

Hi, I seem to be having some issues when display my textures in Unreal Engine(up-to-date) I texture in Substance Painter, model in MODO. The texture in Painter displays perfect but when in unreal it seems to have a smearing effect, the line it’s happening along is a seam.
Things I’ve tried to fix the issue:
Tried toggling Full Precision UV’s, seems to make the area a tiny bit wider
Tried to bake the textures without being triangulated, no difference at all
Tried to give the UV Islands more spacing to see if the texture may have been overlapping, nope
Tried to give 16 texture padding, then 32, no difference at all
Tried to straighten the UV’s as straight at possible and even relax them more, still nope

Hope you guys can help me as I have spent the better part of 2 days trying to fix this, going crazy lol

Unreal
Imgur

Painter
Imgur

I haven’t really used Modo, but if there’s an option, see if you can export the mesh without encoding tangents and binormals. Also, on import into ue4, try setting the import method to “Import Normals.”

Just tried this and it didn’t have any effect on the issue, Unreal by default for me is set to import normals. Thanks anyways!

Just tried to import in Unity and it seems to be the exact same, so this issue is limited to game engines, but in modo, sketchfab, substance it displays perfect. It’s as if the UV’s are shifting slightly on there way into the game engine.

Im a MODO user and rarely expierience those effects.
What are your export settings for fbx in MODO and which exporter are you using, 2013 or 2015?

fbx.png I use the Latest setting

Are you exporting/importing the textures via MODO/UE as well?

If so, try the following (just to see if you get different results)

  • Change the shader type to Unreal Material in the PBR settings.

Also try to use the FBX 2013 exporter to see if it makes a difference.

I don’t import materials, so tried to turn it off and didn’t work.
Also tried to do all of them at once and individually and that didn’t seem to work either, thanks for trying anyways!