texture problem

hi friends I have problem in ue4
when I import a texture and load into mesh in game play my texture is not too sharp is too much blury please tell me how fix this
my texture size is 2k anf format is png-16bit

Can you post a screenshot of your problem? So that it will be easy for others know what exactly is going on.

Best Regards


here is screenshot kindly check this

Lets try this first, double click on your texture and tick never stream. Also check that Mip Gen settings are set to FromTextureGroup and check if it works. If still you face the problem, go to settings and check the engine scalibility settings and set it to epic and see if it made any difference.

Best Regards

okz thanks

Hi. tell me please why my material is wrong? The material created in Substance Painter.

so it should look

so it looks in Unreal

I have Substance Painter, make sure your Roughness and Metallic maps have their sRGB option unchecked in the texture properties in UE4.
There is also this in the answer hub with the very same question.

Thanks for link. I try it and here result:

Substance Painter

Unreal Engine

How you consider, everything is correct?

The way too tiresome seems to me. Substance Painter has special profile for Unreal export. Really they can’t adjust it properly?

It looks correct. Keep in mind that the environment plays a huge part in the rendering of metals in UE4/Substance Painter. If you don’t have the exact same environment, the lighting will look different, but the materials is the same.
On your screenshot, the reaction to the environment looks very similar, so I’d say everything works as expected.

I again had problems with import of the subsequent maps. I had to spend a lot of time to learn to do it. I exported material from Substance Painter in two ways, the first through Substance Designer and the second - simply maps and created the material in UE.


BaseColor: sRGB - on, Compress Without Alpha - off
Metallic: sRGB - off, Compress Without Alpha - off
Roughness: sRGB - off, Compress Without Alpha - off
Normal: sRGB - off, Compress Without Alpha - on

They look the same to me, where are you seeing problems?

Yes, they are the same. I hope that there are no problems. Maybe someone will need these settings.

I see, I thought you were referring to the image above when you mentioned you ran into problems.