Texture loses alpha on export

I picked up some textures from an asset pack. The textures are too large, so I wanted to downscale them in Photoshop.
When I export them though, the alpha disappears. The result looks like the in-engine thumbnail, where the edges bleed all the way out to fill the empty space.
I also can’t find any way to just grab the source files from the asset directly without first adding them to a project, so I’m stuck.
Is there any way to export the textures properly, with the alpha channel intact?

When you open it in Photoshop is the alpha channel info there? And are you sure you are exporting in a format that supports alphas like .tga?

Ah, you’re right. The alpha channel is intact, Photoshop is just refusing to display it for some reason. It’s TGA format, so it should be able to display it fine. Any idea what could be causing that? The problem is unique to assets exported from UE4. The alpha displays fine with other TGA files I have.

What is the alpha doing? Because you can use alphas to do a variety of things. I generally use it as a mask but it can be used to drive specularity, opacity and a few other things. Would you mind sharing one of the files so I can see what’s going on with it?

I can’t share it because it’s an asset I purchased. I’m using it to drive opacity.
The alpha channel is starting out disabled by default in Photoshop, and if I enable it myself, it behaves as a 2nd Red channel. Which is very strange. The normal red channel is also functional.
Enabling it basically just turns the background red.

thats normal alpha behaviour in photoshop.
If you enable it, it shows as a red overlay.

Just be sure you save the tga as 32 bit, and make sure you didnt turn on “save without alpha” in the texture menu in ue4.


How would I get Photoshop to display the alpha properly? It makes editing the textures very difficult.

Goto the channels tab on the right. Disable R,G,B channels to see the alpha