Texture Cubes no longer streaming in 4.23.

I’ve recently been investigating an engine upgrade to 4.23.0 from 4.22.3, and I’m running into an issue with texture streaming Texture Cube objects.

In 4.22, my skybox cubemap textures are able to be streamed in. In 4.23, the same textures are not streamed in. Notice in the image below that the loading method changes between engine versions.

I’ve played around with mip settings, resolutions, and other import settings, but I can’t seem to get any cubemaps to stream in 4.23. Has anyone else seen the same behavior/know how to get around it? I’ve tried converting my spherical .HDR map into a .DDS cubemap, and the same issue occurs, where the method is forced to ‘Not Streamed’ no matter what the import settings are.

Importing the same texture data (resolution, pixel depth, etc.) as an .EXR allows the texture to stream in 4.23 when MipMaps are enabled (turning mips off forces the texture to not stream, for some reason that may be related), but the texture is no longer detected as a Texture Cube.

Any ideas?

I can confirm I’m seeing this in 4.23.1 but I don’t know what the status was in 4.22. I’m seeing a bunch of our materials with cubemaps that have fullsized textures loaded when the object is rather far away.

I talked to epic on UDN and got the guy that worked on streaming to respond and he says that indeed, unreal doesn’t support streaming cubemaps :|. My question is here if you’ve got UDN access ( )