Download

Texture brighter on material than expected

Having a strange issue - textures are showing brighter/more washed out when used on materials than in other software or in the texture preview. Others have had similar problems due to the files being 16bit pngs - I’ve tried other file formats and the issue remains. Anyone come across this before?

You should check your texture in Unreal to make sure it is using sRGB, but honestly, this just looks like the normal result of camera exposure. You can adjust the exposure settings of the preview window and of course in-game you can do it per-camera or via post process volume

Thanks for the ideas - yes, it’s using sRGB and auto exposure is turned off in the project settings.

I don’t think it’s purely a brightness issue - if I darken the image (either directly or by tweaking the exposure in the preview window) I still can’t achieve something that looks the way the texture looks outside of the material, the highlights are underexposed and shadows become too black.

What does it look like when you switch the view mode to Unlit?

Interesting - then it looks correct!

If it is an option you can try setting your material to unlit, though I don’t think that will solve it because I suspect the issue is probably with the post process (unlit view mode ignores post process, but unlit materials still use it, afaik) Unchecking auto exposure in project settings does not disable it, it just makes it set to off by default, and the camera will always have to be set to some exposure level even if it isn’t automatically adjusting.

But, if it isn’t the exposure then it might be the tonemapper. UE4 uses the ACES Filmic standard by default, but a common complaint of Filmic is that it is too contrasty. You can adjust the settings via color grading in the post process, it may be tricky to get a perfectly accurate result though.

You can try mimicin’g the legacy tonemapper, that may work better. There’s a list of settings in that link that will accomplish that

The material is unlit actually, but I tried with a new blank material and no difference.

It sounds like the tonemapping is the most likely culprit, - I guess it’s changing all the textures and I just didn’t notice before, this one must have showed the effect more than most do. Given that the rest of the project looks fine, maybe the only solution would be to fade up a new post processing volume (with the tweaks) when this image appears -_-

Thanks again for the all the help with this, the tonemapping didn’t occur to me!

Why not just darken the image?
as in, add a division factor, set the scalar to 1 so that there is no change.
adjust the scalar on the material until the texture looks OK.

You can multiply too using .01 to .99, but since you need to tone down only, using division allows you to use integers. 2 being half strength. 4 being a quarter and so on.

Oh. To be safe, clamp after the division. It’s not needed but it prevents lower values than 0 or higher values than 1

As mentioned above I tried darkening it and unfortunately this doesn’t solve the issue - it under exposes the highlights and excessively darkens the shadows.

well, the other way around it would be to correct the image in photoshop specifically to counter what the lighting does in engine. Its easier than tone mapping…
also it doesnt affect the rest of the scenes or require crazy PP hacks.

Right yes - this ought to be possible - but is a bit trickier than it seems, I had a few goes at it. I guess I need to play around more…

I’m getting a similar issue with textures in materials. Whether the preview is a sphere or a cube, the material looks darker in the shadowed areas…though also darker in certain lit areas…while lighter (washed out lighter, and brighter than the texture sometimes) in the other lit areas. I tried adjusting RGB Curve, Brightness / B-Curve, Saturation, and Min/Max Alpha. However, those don’t produce the result of reducing the contrasting dark-is-darker / light-is-lighter areas. I think it is the file format, and quite probable it has a connection to how 16-bit is rendering in Unreal and other applications. PNG is known to not have as great of color / tone accuracy as JPG, and when it’s exported / imported with compression, can limit color output. I know because I’ve seen it before, and not only in Unreal.

One other idea is generating a mask of the image somehow to isolate the bright areas from the dark and adding parameterized modifiers to adjust those areas separately for brightness / darkness. It could be created as a material function, or a master material. I don’t know enough of Unreal materials to do it myself yet.