Download

TextRenderComponent blurs on movement with post processing turned on

I’ve got a TextRenderComponent attached to my pawn in order to get around the “HUD not displaying in both eyes in stereoscopic mode” problem. When the Scalability settings of the engine are set to lowest, everything looks great. When the r.PostProcessAAQuality is anything other than 0, or when sg.PostProcessQuality is set to anything other than 0, the text blurs when the pawn starts to pick up speed. It’s worth mentioning also that I’ve got the text material set to use emissive output in order to stop the text from being affected by shadows.

I’d like to be able to continue using post processing effects without the text blurring, does anyone have any insight?

Sounds like TemporalAA, locate that in the post process volume and try turning it off there. That probably fixes it, but that also removes the nice AA… Alternatively there is an option in the material that runs your font, something along the lines of Responsive AA or whatever the name was. That doesn’t solve it entirely though, but it helps.

Also motion blur may have an impact. COuld be worth setting the intensity of that to 0 in the post process volume.

Hmm, appreciate the suggestion. It’s looking like, however, that the main problem is the post processing in general, not the AA. I was probably a bit too vague in my original post, turning off the AA gets rids of some of the jitteryness, but it still blurs unless I turn of post processing entirely (sg.PostProcessQuality 0). Even when the GlobalPostProcessVolume doesn’t actually have any effects enabled the blur still occurs. Which is the real problem.

Actually, even more interesting is the fact that the problem persists even when I go into the GlobalPostProcessVolume and deselect the “enabled” property. The problem is only fixed when I turn off post processing at the engine level (sg.PostProcessQuality 0)… hmm…

Aha, didn’t realize that the defaults aren’t necessarily 0. Set motion blur amount to 0 and that did it!