TextRender not visible on ios

Hello,

You are correct, this has not been fixed for 4.3, 4.3.1 or 4.4 preview, however the report has just recently been updated as fixed and verified by our internal QA. The fix will go to the public binary in an upcoming release soon.

Thank you,

Alexander

I have started to get this issue since i updated to 4.4.2. I updated to 4.4.3, but the issue still exists.

Can someone please confirm?

I have started to get this issue since i updated to 4.4.2. I updated to 4.4.3, but the issue still exists.

Can someone please confirm?

Hi,

I am a bit confused by this, we have not created a 4.4.3 build for UE4. Do you mean you using a source build of 4.5? If you can clarify that, we will be able to test the issue and investigate further.

Thank you

Hi Alexander ,

Thanks for your quick reply. I checked out from the git source branch 4.4 and tagged as 4.4.3. I found it had bunch of problems when trying to run it on the iPhone 5s device.

The other problem was the papersprite won’t be visible on the device, but will be visible in the mobile preview. The lightning was completely different on device that from the preview.

So to confirm, I created a production package and installed on my phone from iTunes. But, the issue still existed.

Please let me know if you further need more information.

Hi codingfornirvana,

Does this occur on a clean project with no additional content? Additionally, does this occur in the mobile preview mode or only after packaging and launching on an iPhone device?

When u say additional content , do u mean third party content ? The only additional content I added was a static mesh from blender. This only happens after packaging and launching on the device. The preview mode works great.

Hi codingfornirvana,

What I mean is, if you create an absolutely blank project and add nothing to it (including the starter content from the editor), then you create a text render actor and launch to a device, does this bug still occur?

Let me try it tonight once I reach home.

So i tried in Unreal 4.4.2 , since i checked out 4.4.2 from repo as 4.4.3 wasn’t working for text. I did a fresh start and completely new project.

Here is how it looks like on the device.

The vertical boxes are suppose to be text.

Does this occur when you change the font style?

try changing to a different font. To access them you may have to enable engine contents in the view options menu of the content browser.

Its the default style. I never changed the style or font. It works fine in the preview, but happens when i install on the device.

ohh i did not try that. Let me try it tonight. Thanks.

I tried to use the fonts from the engine, but the other fonts are completely busted. They are not properly visible in Preview except “RobotoDistanceField”, which works only in preview.

Hi codingfornirvana,

I just tested on an iphone 5S and was able to see the textrender actor in tappy chicken. What model of iOS device do you have? This may be device specific.

I am having iPhone5s, iOS 7. I remember seeing the text working fine when the text was loaded directly from the project.

The text renderer was not working when i was trying to create one.

Hi everyone,

I was able to reproduce this on my end and have entered in a bug report, TTP#347624 to be assessed by the development staff. Thank you and have a great day!

Phew !! I thought i was doing something wrong.

Thanks :slight_smile:

Hitting this now (textrender works fine on PC and MAC but not visible on iOS8 loaded iPhone5 NOR in mobile preview. Can’t see a solution in the above thread - there must be one but what is it?