TextRender not visible on ios

I’ve built a project where I am using TextRenderActor to display some text but when I run it on the iPhone device and on the Mobile Preview, the text is not visible.

What is going on and how can I fix it.

Cheers,
Andrew

Hi adoug,

This is a known issue that is currently being assessed by the development staff. Thank you and have a great day!

Is there any text rendering functionality that is available on ios? Is there a minimal working implementation of TextRenderActor that I can use while this issue is being resolved?

hi,

in 4.2 version same issue…

,Hi,

In unreal engine 4.2 this the same problem… the text is not visible.

Had the same problem and fixed it by setting the font material to “Unlit and Transluscent”. (works on my Android device), also you can check the TappyChicken sample.

Again, I’m not sure if it works on iPhone devices, you can try and tell us the result ?

Cheers

I change to Until and translucent. doesn’t work…

But with TappyChicken the texture material work fine.

Have a special font texture ? or you use the system engine font ?

Tried with a new Font (you can easily create one within UE)

Be aware that in 4.1 (haven’t tested it on 4.2), anytime you make a modification on a font, you’ll have to compile it, close it and re-open it to see the modification applied.

What’s the status of this feature?

4.3 This is still an issue, what is the status of this? Hardly can make a game with out ‘Text’

Hi everyone,

When specifically is the error occurring? Can you see the text in mobile preview but not in a packaged product? Does it show up in standard viewports? Has this occurred in a clean project with no additional content? Thank you!

I’m not seeing it in the mobile preview. I haven’t tried recreating my project in 4.3 , I created it in 4.2. Though I hope that’s not the solution, I’ll try it. I guess this implies the issue has been fixed at some point?

Hi Awdogsgo2heaven,

Yes, if it works in 4.3 that means that most likely it was altered or fixed at some point. What devices are you currently packaging for?

iOS primarily.

Hi Awdogsgo2heaven,

I mean what specific phone or table models are you working on? This can help us to see if there are specific devices this is not working properly on.

I tested this on iPhone 5, and iPad 4, in both the Text from Text Renderer will not show, It won’t show in the Mobile preview either. I also tried creating a ‘Blank’ project, add a Text Render Actor to it, and then use Mobile Preview and it didn’t show.

Hi Awdogsgo2heaven,

I was able to reproduce this on my end and have entered in a bug report to be assessed. Thank you!

Thanks Adam. Do you guys have a public bug tracker so we can watch the progress on these bugs?

Hi Awdogsgo2heaven,

Currently we don’t have a public bug tracker.

Doesn’t work for me on 4.3 either.