Download

Tessellation near clipping plane error

Hi,

Ive been looking around for a solution here but cant seem to find much. I seem to have this clipping plane issue on my tessellated mesh. You can see below. Ive adjust the project settings and enabled the crack free in my material. It look as though its only occurring in camera space. when i tilt the camera it moves into the distance on the mesh. Its clearly noticeable when in wire frame mode but it its trying to correct itself in the texture modes. Is there a solution to this or is this the limitation?

Ive included a small clip and an image of the mesh im using. Ive added alot more verts to help.

https://youtube.com/watch?v=YavzN6KLVQ0

tessellation-mesh.png

Thanks for the help

seems your entire place is displaced quite some distance above the pivot point which messes up with camera/bounds/frustum calculations for tessellation
try increasing the Max Displacement value in your material to a number higher to how much you’re displacing it. it will also help if your displacement is vertically centered around the pivot instead of going that far up from it.

Hey Chosker!

Changing the max distance in the material fixed it. Thank you! I had left it at 0. One more question, by pivot point do you mean the on-screen transform widget? The only way i can think of achieving the vertical placement at the origin is to have a low spot right at the middle point?

I mean the way your displacement works. it just moves up in relation to the pivot point. don’t just make your displacement positive, but instead make it half positive and half negative so you end up with displacement going up or down in relation to the pivot

Ah ha perfect! i totally get it thanks!

So after messing around with these parameters, i come to find everything in my scene is broken. all the elements will not move in the viewport, colors are different, billboards are all oriented in the z vector. My sky BPs are not responding. Ive been experimenting with persistent levels, so I was manipulating the tessellated mesh in a level that i applied to my base… I have about 5-6 more level that im turning on and off frequently. They alll broke… Do you think that the tessellation could have broken everything? I have the displacement set to a high amount. 5000 units.

When i try to rotate the BP to get the billboard to rotate, it moves but stays in the same orientation… the translate widget does nothing, but the rotate widget functions.

Everything is pink… the same color as the material that i was using to displace. Textures are missing from other elements… it really seems like that it broke my entire project… super disappointing.

I would call myself a middle level user. but at this point im afraid to migrate the assets over to a new project because i have no idea what has caused this or whats going on under the hood. I live in BP land.

Update:

So the entire project was showing the same effects. across all pre-existing levels and any new that I created. no idea why… but i know it had something to do with the tessellation testing i was doing. Ill definitely be aware of this in the future. Perhaps there is a max distance threshold that I crossed.

I had to recreate a project, then migrated all my Blueprints and everything was back to normal.

What “tessellation” were you messing with? If it was just the parameters within the landscape material, then no. Whatever you do there won’t affect other levels.
if it was the global tesseletion setting sin project settings, you can always revert to the original values…

Also, the issues you describe are more consistent with floating point precision issues then anything else… except opening a new level should revert back to whatever that level is set to for position…

Hey MostHost!

Thanks for chiming in. I was using a landscape at one point, but I was noticing more artifacts so i switched over to a high poly, imported mesh plane. The material was merely using texture samples, which included a height map that i was tessellating, very much if i may say, inside the material itself. I never changed the max distance until it was mentioned above. I assumed leaving at 0 would allow no bounds to be considered? I often find myself stumbling around unreal to find my way, so i really have no idea the “proper” way to go about it. displacing from the center sounds promising. also knowing the bounds of the simulation.

A bit of paranoia pushed me to delete the project file when i gathered what assets I wanted to save, but i tried to put into detail above the situation. It only took a couple hours to get another project back into the same position i was before.

Im coming from a similar environment, Touch Designer, so data isnt above me, more of how it is processed inside the engine. With the floating points…Perhaps there was too much overlapping data, and it became corrupt…once again, above me.