Terrible graphics quality change in Quest. How can I improve it?

Hi guys!

I finished making a small game for Oculus Rift, and decided to bring it to Oculus Quest 1.

I just launched it to Quest and now it looks like this.

Windows Media Player 2021_01_13 3_16_17.jpg

The original is below.

pc-lowres.jpg
I didn’t expect the same quality, but this is so terrible.
In HMD it looks worse. Textures are super jaggy, and Also, an explosion particle(at the center of the image in the Quest one) is far from the original.

I tried MobileHDR with Vulkan for post processing, and I could see some effects like bloom, but it didn’t improve much.
Also, I set r.MobileContentScaleFactor to 0, but no change.

Unreal Engine seemed to significantly lower graphics quality like texture resolutions for mobile, but I don’t know how I can make the engine stop doing that.

Can you please help me improve this?

1 Like

And here is my DefaultEngine.ini. I changed rendering settings and android settings a lot for my project. I believe that doesn’t lower the mobile graphics but maybe.

So now I set Scalability settings, and my device profile looks like this.

But it didn’t change the graphics quality…
The first image I posted looked fine, but in my HMD things looks so jaggy and it is not playable at all.

Especially particles, characters (I use default mannequin) and blossom trees(from Infinity Blade) looks terrible as if they are from PS1 game and have no anti aliasing.

I am trying to solve this issue for a whole week, but I am not sure what I should do now…

forgot to mention that I set vr.Density to 1(default), but still so jaggy.

No one sees this?

Please give some advise to me…

I’m just getting started with UE development for Oculus, but I’ve run into the same exact thing and I would like to figure that out before I continue, because, even the template VR project looks like ■■■■. Did you find a solution?

I launch UE5, switch to DirectX11 because DirectX12 crashes the VR template, package and the quest2 lighting is awful. Lighting and shadows seems to be awful on mobile devices and the Quest.

Looks like nobody reads it! I’ve been facing same problem over and over. Never found a solution for this.

Hi there! just starting now with oculus quest vr in Unreal and have the same problem with resolution and framerate, any news about this?

Any solution? i have the same problem with oculus quest 2

I have no idea.

you can force higher lods and even delete some of them
you can disable low and medium overrides in android
disable ogl
use mobile particles
foliage using transparency will often look like crap
you can also force textures to not mip