TemporalAA damaged in playmode

Hey there !!

Every day new problems with UE4.
This time I have the following problem:
I have a nice (matinee) cut-scene that looks totally nice and everything working fine.

When the cutscene is over and the view switch to player, suddely the temporalAA is defect…befor is not.

I checked postFX, I made all textures poweroftwo, tried some ather rendersettings, but whatever I do I still get the same issue.
What I added befor the bug came up first time was a animated character and 2 mediatextures, and I deactivated the crosshair…thats all.

In editor I also saw this problem but after restart engine it was always gone.

SCR from matinee-cutscene (temporalAA working fine):

SCR after cutscene, when start fp-controller (temporalAA cause heavy flickering on edges):

…it is so heavy distorted, that you can easily see it in this low res.


Same problem on different maschines.

In editor when this problem takes effect, I found out, it’s enough to switch to matinee and than back…than it’s gone again.

Hey Schindelar3D,

Have you tried using the ‘Movie’ option within the ‘Matinee’ itself?

Movie Button within Matinee

This button allows you to render out a movie with various options. I responded to a user who wanted to render a video sequence as well and I gave him some steps to follow in order to do so.

Render Out Videos

If you need more assistance or want to go about rendering with an external application let me know.


Thanx for the answer, but you have not understand my problem. I’m not trying to render a video. For that I would use octane and my modeler not a game-engine.
I’m building RT-Archviz with intro-sequence and than fp-controle to move around and a ui for configurate the rooms environment/colors and so on.

In my case it is a problem with the temporalAA witch looks much better than FXAA but witch cause problems here. The strange thing is that while the matinee is running tempAA works fine, but as the playerCam starts the tempAA is going crazy.

I still cannot find the reason.

By the way I had about 30 crashes only the last 2 days with UE4.

Sometimes when adding a material in scene-view.

Always when try to switch mediamaterial (with video) from url stream to memory

Sometimes when stopping playmode and go back to editor.

Many times when adding new objects to content browser.

Sometimes while matinee-editing…

it’s a mass !!!


It was a problem in my level blueprint.

I constantly triggert the matinee-start. That was no problem as long as the matinee was running, but at its end, when cam is on player and matinee-timeline is over, if start is still triggered, those crazy AA-error was caused. Strange, but otherwise I would not find this fail.

Thanx for trying to help !!