TemporalAA consumes render time even when disabled in the project settings and PostProcessVolume

when I render a simple scene (5.85ms), the GPU profiler indicates that some time (0.61ms) is spent on “SSRTemporalAA”, which I assume refers to the TemporalAA pass - even though I disabled it both in the project settings as well as in the GlobalPostProcessingVolume settings. Also, the scene is rendered without TemporalAA as it should be.

Is this a bug, or what does this mean? Is there a way to completely disable TemporalAA, so that it stops taking up rendering time?

I sort of solved it by setting the Anti-Aliasing setting in “Engine scalability settings” to low.

It’s a thing with SSR, i.e. ScreenSpaceReflection. I’ve managed to disable this by killing SSR at all; but it persists even when I do as you said and set the scalability setting to low. I can’t find a way to keep SSR without this…

The problem is that quite some effects in Unreal Engine are depending on a Temporal AA Pass. So even if you disable it and no longer see the effect of TAA, it will be calculated since its needed by some Effects (like SSR) and those wont work without it.

Its actually the some with some other postprocessing effects you will see in a gpuprofile, some effects depend on each other, like color grading / tone is being calculated most of the time even if you disable it, since other effects depend on it.